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 このチュートリアルの目的は、以下のパラメーターで DC/DC バックコンバーターを作成することです： 

 入力電圧 = 12V 

 出力電圧= 1.2V  

 出力電流 = 10A 

 スイッチング周波数= 500kHz 
 

このチュートリアルでは以下の方法についてご説明します： 
 SIMetrix/SIMPLIS 回路図エディターを使って open loop power stage 回路図を作成する方法 

 SIMPLIS の 3 つの解析手法（POP、AC、過渡解析）を使って設計のシミュレーションを行う方法 

 出力曲線を生成し、自動的なスカラー測定をこの曲線に行う 

  3-ポール, 2-ゼロ 電圧モード補償器を電力段に付加して、フィードバックループを閉じる  

 コマンドウインドウ(F11) で表現と.VAR ステートメントを使ってパラメータ化した値を付加する  

 コンバータの小信号、大信号の安定度を検証する 

 回路図の補償器の部分でどのように階層構造の回路図の部品をつくるか。この階層構造のブロックは他

の設計に再利用できます。 
 
 

 

Topics in this tutorial 
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Topics in this chapter 
1.0 Getting Started with the SIMPLIS Tutorial 
2.0 Entering the Design 
3.0 Simulating the Design 
4.0 Managing Simulation Output 
5.0 Building High-Level Models 
Conclusions 
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このチュートリアルでは、バックコンバーターの設計プロセスを、最初の作図から始まりパラメーターを設定した最終

的な階層設計に至るまで、順を追って説明します。すべての回路図および関連ファイルはこのチュートリアルを進めて

いく中で順にダウンロード可能ですが、同じものが次のセクションで zip ファイルの形でまとめてダウンロードできま

す。 
 

 
 
 

 
 

このチュートリアルでは回路図のコピー、その他のファイルと製品版の SIMetrix/SIMPLIS.が必要です。製品版の

SIMetrix/SIMPLIS.の評価用ライセンスがありますのでご要望下さい。 
 

すでにご自身の PC に SIMPLIS がインストールされている場合には、バージョンが 8.00d またはそれ以降であるこ

とをご確認ください。インストールされたバージョンを確認するには、メニューバーから Help > About... を選択

しダイアログを開けて SIMetrix/SIMPLIS のバージョンを表示して下さい。 
 

 
T 最新版にアップデートするにはメニューバーから Help > Check for Updates... を選択してください。 

 
チュートリアルのファイルは以下のステップに従ってダウンロードします。 

 このチュートリアルで使われるすべての回路図が入った zip ファイルをダウンロードするには、こちら

をクリックしてください：simplis_tutorial_examples.zip. 

 製品版の評価ライセンスをご要望下さい。 

SIMPLIS welcomes your feedback (positive, negative, bugs, etc.) regarding this tutorial. To send comments, click here. 
 

 

 
 

 

このチュートリアルは、新しいユーザーの方々が SIMPLIS シミュレーターを使い始める際の手助けとなること、また

1.0 Getting Started with the SIMPLIS Tutorial 

In this topic: 
 
 

1.1Downloading the Files 
1.2Tips for Navigating this Tutorial 

1.2.1 Navigation Conventions 
1.2.2Text Conventions 
1.2.3Schematic Images 

 
1.3  SIMetrix/SIMPLIS Environment 
1.4  Setting General Options 
1.5Showing the Part Selector 
1.6Setting up the User Interface for the Tutorial 
1.7  Creating a New Schematic 
1.8Saving your Schematic 
1.9Add Working Directory to the File View 

1.1 ファイルをダウンロードする 

1.2 このチュートリアルの操作方法 

http://www.simplistechnologies.com/documentation/simplis/library/examples/simplis_tutorial/simplis_tutorial_examples.zip


1.0  Getting Started - SIMPLIS Tutorial 
 

3  

SIMPLIS の全般的な参考資料となることを目的としています。SIMPLIS の使用経験のある方は、左側にあるリンクを

使い、不要な部分は飛ばして別のセクションに進んでください。 

 

 
 

サブセクションのあるトピックについては、ページ先頭に簡単な目次が記載されています。各セクションの最後には

back to top のリンクがあり、そこをクリックすることで目次に戻ることができます。 

閲覧の順序については、ウィンドウの上部に左右の矢印があります： 
 

 左の矢印⇦Previous topic…前のトピックへ戻る 

 右の矢印⇨ Next topic…次のトピックへ進む 

 The ⇧ Parent topic goes to the main section topic; that is 1.0, 2.0, etc. 

 
 

 
 

内容を読みやすくするために、テキストは次のきまりに従って表示してあります。 

 太字のテキストは通常、画面上で選択するものやキーボードで入力するものを示しています。ファイル

名も太字で表示されています。 

 緑の斜体は、番号の付いた手順を行った後に起きる結果を示しています。 

結果：緑の斜体... 
 メニューの選択方法については、メニューの項目を▶で分けて表示しています。例えば、File▶ Save は

「メニューバーから、File をクリックし、次に Save を選択してください」という意味になります。 

 
 

 
 

 
 

回路図 have のスクリーンショットでは見やすくするためにレイアウトグリッドはオフとしてあります。 
 

Hide grid オプションはデフォルトでオフとしています。作業の間グリッドが見えるようにしておけば、回路図で

シンボルを置いたり配線したり するのに助けになります。 
 

回路図エディターのメニューView > Toggle Grid でグリッドオンやオフに変えられます。 
 
 

 
 

SIMetrix/SIMPLIS ソフトウェアパッケージには 2 つのシミュレーターが含まれています： 

 SIMetrix シミュレーターは、優れた収束性を持つ、最適化された SPICE シミュレーターです。 

 このチュートリアルで扱う SIMPLIS シミュレーターは、スイッチング電源設計用に最適化された区分線

形（PWL）シミュレーターです。 
 

Beginning with SIMetrix/SIMPLIS version 8.0, SIMetrix/SIMPLIS has an integrated user interface with a single Main 
Window and a set of sub windows called System Windows which can be moved or docked on the periphery of the main 
window. 

SIMetrix/SIMPLIS の主なウィンドウには次のようなものがあります。 
 The Welcome Page contains links to open recently used files, to access the documentation system, etc. 

1.2.1 操作に関するきまり 

1.2.2 テキストの表示に関するきまり 

1.2.3 回路図のイメージ 

1.3  SIMetrix/SIMPLIS の環境 
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 Schematic editor（回路図エディター）は、回路図を編集する際に使用します 

 The Waveform Viewer window opens to display output curves after you have run a simulation.  

 シンボルエディターは、シンボルの作成や修正に使用するツールです。 

 

The System Windows include these: 
The Command Shell displays error messages. 

 Note:  In the full versions of SIMetrix/SIMPLIS, the Command Shell includes a text field for entering 
script commands. 

The Part Selector is where you find symbols to place on a schematic. The part selector is populated with symbols 
based on the simulator mode of the schematic (SIMetrix or SIMPLIS). 
The File View allows easy access to your file system for opening files in SIMetrix/SIMPLIS. You can add your 
commonly used directories to the file viewer. 

Finally, when a SIMPLIS simulation is launched, the SIMPLIS Status shows the progress of the current SIMPLIS 
simulation. 

 
▲ back to top 

 
 

 
 

SIMPLIS を初めて使う際には、様々なオプションがデフォルト設定になっています。このチュートリアルでは、新たな

回路図に SIMPLIS シミュレーターが使用されるようにするために、シミュレーターモードを変更する必要がありま

す。オプションはすべて、SIMetrix/SIMPLIS メインウィンドウまたはツールバーボタンを通じて制御します。 
 

デフォルトのシミュレーターモードを変更するには、次の手順に従います： 

1. スタートメニューから SIMetrix/SIMPLIS を起動します 

結果：SIMetrix/SIMPLIS のメインウィンドウが開きます 

2. SIMetrix/SIMPLIS のメインウィンドウで、File > Options > General....をクリックします。 
 

1.4 全般的なオプションを設定する 
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3. Options をハイライトし、General...をクリックします。 

結果：Options/Preferences ダイアログボックスが開き、Schematic タブが表示されます。 

4. 右上の Initial Simulator セクションに行き、SIMPLIS ラジオボタンをクリックします。 
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5. Ok をクリックします。 

結果：全般的なオプションはユーザープロファイルに保存され、SIMetrix/SIMPLIS を閉じた後も保持されま

す。You may have also noticed the Welcome Page was refreshed after you clicked Ok on the dialog. In 
particular, the icon at the top of the page changed from the SIMetrix icon to the SIMPLIS icon. In the Create 
New section of the Welcome Page, the icon next to the Schematic link also changed to a SIMPLIS icon, 
indicating that each new schematic created will use the SIMPLIS simulator.  

 
▲ back to top 

 
 

 
 

SIMetrix/SIMPLIS のデフォルト設定では、パーツセレクターは非表示になっています。このチュートリアルではパーツ

セレクターからシンボルを配置するため、シンボルを配置し始める前に、まずパーツセレクターを表示させる必要があり

ます。 
パーツセレクターを表示させるには、View > Show Part Selector メニューを選択します： 

結果：メインウィンドウの右側にパーツセレクターが表示されます。 

1.5 パーツセレクターを表示する 
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▲ back to top 
 
 

 
 

前のステップでパーツセレクターシステムウインドウが表示されました。この章では SIMetrix/SIMPLIS メインウインド

ウの左側に全てのシステムウインドウ移動します。パーツセレクターを動かすには以下のステップに従います。: 

1. パーツセレクターシステムウインドウの上の灰色のバーにマウスカーソルを動かします。 

結果：マウスカーソルがポインターから開いた手に変化します。 
 

 
 

2. 押して左マウスボタンを保持します。 

結果：開いた手が閉じてパーツセレクターシステムウインドウは動かせる状態になります。 
 

 
 

3. マウスの左ボタンを押している間、パーツセレクターシステムウインドウを左にドラッグします。ウインドウを

ドラッグするとメインウインドウの部分が明るい青に変わるのが分かります。左ボタンを離した時にシステム

ウインドウがどこに置かれるかのしるしになります。以下はファイルビューシステムウインドウのタブに重ね

られて、パーツセレクターシステムウインドウがメインウインドウの左側に配置されるイメージです。 

1.6 チュートリアル用にユーザーインターフェースを設定する 
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4. ァイルビューシステムウインドウにパーツセレクターシステムウインドウを配置するためにマウスのボタンを離

します。 

結果：パーツセレクターとファイルビューシステムウインドウがタブで一個のシステムウインドウになりま
す。 

 

 
 

5. この操作をコマンドシェルシステムウインドウでドラッグして他の二つに繰り返します。 

結果: 全ての三つのシステムウインドウはタブで一つのウインドウになっています。チュートリアルではこの

システムウインドウの形態を使います。 
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新しい回路図を作るには以下のステップに従います: 

1. Welcome Page で Create New セクションで Schematic をクリックします。. 
 

 
 

結果: 新しい回路図が開けられます. 

2. 右下側の隅でモードが SIMPLIS となっているのを確認します。. 
 

 
 
 
 

 
 

この時点では、回路図は白紙で、シミュレーターモードは SIMPLIS になっています。回路図を保存するには、次の手順

に従います。: 

1. File > Save Schematic を選択します。 

1.7  新しい回路図の作成 

1.8 回路図を保存する 
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2. 作業ディレクトリーとして使える場所（このチュートリアルで作成する回路図を保存できる場所）を指定します。

このチュートリアルでは D:\SIMPLIS Tutorial を使用します。 

3. ファイル名は 0_my_buck_converter.sxsch とします。 
 

▲ back to top 
 
 

 
 

ファイル閲覧システムウインドウに作業ディレクトリーを追加すると、ファイル閲覧システムウインドウにチュートリ

アルで使う回路図ファイルに簡単にアクセスできます。ファイル閲覧にディレクトリを追加するには以下のステップで

行います。 

1. Click on the File View tab in the system window. 
Result: The File View system window comes into focus. 

2. Click on the Add Directory button. 
Result: A directory browser window opens to the current directory. 

3. On the directory browser, click Select Folder 
Result: The directory is added to the File View system window. 

 

 
 

4. To see the contents of any directory in the File View, simply double click on the directory. 

Result: The directory contents are displayed with the 0_my_buck_converter schematic being the only schematic 
file in the directory. 

1.9 ファイル閲覧のため作業用ディレクトリーを加える 
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▲ back to top 
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Entering the Design 

2.0 設計を入力する 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/2_0_entering_the_design.htm[2016/05/05 9:36:30] 

 

 

 

チュートリアルのこのセクションでは、1.0 はじめにで作成した白紙の回路図を使い、以下のやり方について学んでい

きます。: 

 パーツセレクターとキーボードのショートカットを使ってシンボルを追加する 

 回路図に配線を追加する 

 余分なシンボルや配線を削除する 

 シンボルを編集し、様々な変更を加える 
 

シンボルを配置し、配線をつなぎ、コンポーネントの値を変更すると、回路図は以下のようになります： 
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Topics in this chapter 
2.1Add Symbols and Wires 
2.2Edit Standard Component Values 
2.3 Edit Multi-Level Models 
2.4 Edit Parameter-Extracted Models 
2.5 Change to a User-defined Model 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/2_0_entering_the_design.htm
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http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/2_1_add_symbols_and_wires.htm[2016/05/05 9:37:09] 

 

 

 

 
 

チュートリアルのこのセクションでは白紙の回路図からどのように設計を開始するかを述べます。 
 
 

 
 
 

 
 

This topic addresses the following key concepts:  
 パーツセレクターの Commonly Used Parts（よく使うパーツ）カテゴリーには、ダイオードと MOSFET を

除き、この回路図に使うシンボルがすべて含まれています。 
 The SPICE models for discrete semiconductors, such as diodes and MOSFETs, are not directly used by 

SIMPLIS. Instead, a parameter extraction system uses SIMetrix to simulate the SPICE model and a set of 
curve-fitting algorithms generate a PWL model for use in SIMPLIS. This process happens before the symbol is 
placed on the schematic. 

 Discrete semiconductors can be placed from the model library or by using keyboard shortcuts. 
 
 

 
 

In this topic, you will learn the following: 
How to verify and change the simulator mode. 
Three ways to place symbols on a schematic: 

By using the Part Selector. 
By placing symbols from the model library. 
By using built-in keyboard shortcuts. 

How to wire symbols together to create a circuit. 
How to remove symbols and wires from a schematic. 

 

 
 

まず、回路図エディターの右下を見て、シミュレーターのモードが SIMPLIS になっていることを確認します。

2.1 シンボルと配線を追加する 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
Getting Started 
2.1.1Place the Symbols 

Step One: Place First Three Symbols 
Step Two: Place Remaining Symbols 

2.1.2Add the Wires 
2.1.3Remove Extra Symbols and Wires 

Special Case: Wires Inside a Symbol Boundary 
Special Case: Wires Which are Exactly One Grid Square Long 

 
2.1.4Save your Schematic 

Key Concepts 

What You Will Learn 

Getting Started 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/2_1_add_symbols_and_wires.htm
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 モードが SIMPLIS になっている場合には、そのままセクション 2.1.1 へ進みます。 

 モードが SIMetrix になっている場合には、Simulator > Switch to SIMPLIS Mode を選択してシミュレータ

ーのモードを SIMPLIS に切り替えます。 
 
 

 
 

This section demonstrates the three ways to place symbols on a schematic and is divided into two general steps: 
In Step One, you will add three symbols to illustrate the three ways to place symbols on a schematic. 
In Step Two, you will place the remaining symbols used in this design. 

 
 

 
 

パーツセレクターの Commonly Used Parts（よく使うパーツ）カテゴリーには、ダイオードと MOSFET を除き、こ

の回路図に使うシンボルがすべて含まれています。therefore, you will place the diode from the model library and then 
use a built-in keyboard shortcut to add the MOSFET. 

 
In this step, you will place the first three symbols, an inductor, a diode, and a MOSFET. Use the illustration below as a 
general guide to place the symbols on the schematic. 

 

 
 

Inductor: To place the inductor (L1), follow these steps: 
1. From the Commonly Used Parts list, double click Multi-Level Lossy Inductor (Version 8.0+). 

結果：インダクターが画面上に表示されます。 

2. Move the mouse to where you want to place the symbol, and press the left mouse button. 

結果：L1 という参照名の付いたインダクターが配置されます。 
 

ダイオード：モデルライブラリからダイオード（D1）を配置するには、次の手順を行います 

1. パーツセレクターで Discretes カテゴリーをダブルクリックし、リストを展開します 

2. Diodes カテゴリーをダブルクリックし、続いて Select from Model Library...をクリックします。 

結果：Select Device ダイアログが開きます。 

2.1.1 シンボルを配置する 

ステップ 1：最初の 3 つのシンボルを配置する 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/2_1_add_symbols_and_wires.htm
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3. Select Device ウィンドウの左下の Filter 欄のアスタリスク（*）の前にカーソルを合わせ、D1n41 と入力しま

す。 

結果：使用できるアイテムとして、D1n4148 だけが表示されます。 

4. 下図の通り、右上の D1n4148 を選択し、Select Device ウィンドウの下部にある Place ボタンをクリックしま

す。 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/2_1_add_symbols_and_wires.htm
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結果：Extract Diode Parameters ダイアログが開きます。 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/2_1_add_symbols_and_wires.htm
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5. Extract をクリックしてデフォルト値を受け入れ、ダイアログボックスを閉じます。 

Result: Several SIMetrix SPICE simulations are run on the SPICE diode model and curve-fitting algorithms 
calculate a set of PWL parameters for use in SIMPLIS simulations. 

 Note:  Although a small-signal diode such as the D1n4148 is not appropriate for a synchronous 
rectifier application, you will change this diode model later in section 2.2 Edit Standard Component 
Values. 

6. 十字カーソルをインダクターの左下に持っていき、マウスの左ボタンを押します。 

結果：D1 という参照名の付いたダイオードが配置されます。 

7. ダイオードを選択した状態で、F5 を 2 回押し、ダイオードを 180 度回転させます。 
 

MOSFET：キーボードのショートカットを使って MOSFET（Q1）を配置するには、次の手順に従います。 

1. マウスのカーソルをダイオードの真上に持っていき、M と入力します。 

 Note:  The letter M is a keyboard shortcut which places a 3-terminal N-type MOSFET, as if you have 
navigated to the Select Device dialog as in Step 4. 

結果：Extract MOSFET Parameter ダイアログが開きます。 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/2_1_add_symbols_and_wires.htm
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2. Extract をクリックしてデフォルト値を受け入れ、ダイアログボックスを閉じます。 

Result: As with the diode placed in the previous step, several SIMetrix SPICE simulations are run on the 
MOSFET model and curve-fitting algorithms calculate a set of PWL parameters for use in SIMPLIS simulations. 

 Note:  The original SPICE model is NOT used in the SIMPLIS simulations. As with the diode, you will 
change the part number for the MOSFET in section 2.2 Edit Standard Component Values. 

3. 十字カーソルをダイオードの真上に置いた状態で、マウスの左ボタンを押し、シンボルを回路図上に配置

します。 

結果：Q1 という参照名の付いた MOSFET が配置されます。 
 
 

 
 

To place the remaining symbols, follow these steps: 

1. 次のいずれかの方法を用い、下記の表 1 に記載されている順序でシンボルを配置します。 

 パーツセレクターの Commonly Used Parts のカテゴリーから、パーツ名をダブルクリック

する。 

または 

 表 1 にキーボードショートカットが記載されているものについては、そのショートカットを

入力する。 

2. シンボルがグリッド上に表示されたら、下記の図に示されている位置までマウスを動かし、マウスの左

ボタンを押してシンボルを配置します。 

ステップ 2：残りのシンボルを配置する 
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ラベル Commonly Used Parts ショートカット コメント 
C1 マルチレベルキャパシター（レベル 0～3、数量

付き）（バージョン 8 以上） 
 キーボードショートカットなし 

R1 抵抗器（Z 型） 4  
V1 Power Supply 電源 v  
V2 波形発生器（パルス、ランプ…） w . 

R2 抵抗器（Z 型） 4 F5 を 3 回押して、270 度回転させる 

 アース g  
Probe1- 
NODE 

プローブ－電圧 b  

Probe2- 
NODE 

プローブ－電圧 b  

IPROBE1 プローブ－直列電流  キーボードショートカットなし 
 

注：誤って余分なシンボルを配置してしまった場合には、Ctrl+Z を押すか、メニューバーから Edit ▶ Undo を

選択すれば、すぐに削除することができます。その場ですぐに削除しなかった場合の対応方法については、2.1.3 
余分なシンボルや配線を削除するを参照してください。 

 
▲ back to top 

 
 

 
 

In this section, you will learn how to add connecting wires to a schematic. 
 

To wire your symbols together, use the diagram and steps below as a general guide: 

2.1.2 配線を追加する 
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1. シンボルピンの上にマウスのポインターを置きます 

結果：ポインターが鉛筆の形に変わります－これは、回路図が配線モードに切り替わったことを示します。 

2. 配線のセグメントを開始するには、マウスの左ボタンをクリックします。 

3. 角の点を作るには、つなげるシンボルに到達するまで、マウスの左ボタンを再度クリックします。 

4. 一つのセグメントが終わったら、マウスの右ボタンをクリックするか、Esc キーを押します。 

注：誤って余分なシンボルを配置してしまった場合には、Ctrl+Z を押すか、メ 
ニューバーから Edit ▶ Undo を選択すれば、すぐに削除することができます。その場ですぐに削除しなかった場合

の対応方法については、2.1.3 余分なシンボルや配線を削除するを参照してください。 
 

▲ back to top 
 
 

 
 

This section explains how to remove symbols and wires individually and in groups. 
 

一つ一つのシンボルや配線を削除するには、次の手順に従います： 

1. 削除したいシンボルまたは配線をクリックします。 

結果：シンボルまたは配線が青に変わります－これはそのシンボルまたは配線が選択されたことを示しています。 

2. Delete キーを押します。 
 

複数の余分なシンボルや配線をまとめて削除するには、次の手順に従います： 

1. 選択ボックスで囲むには、マウスの左ボタンを押したまま、反対側の角までドラッグします。 

2. 範囲を指定したら、マウスのボタンを離します。 

結果：ボックス内の配線（およびシンボル）が青に変わります－これはその配線やコンポーネントが選択された

ことを示しています。 

3. Delete を押します。 

結果：選択された配線とコンポーネントが回路図から消えます。 
 

注：余分な配線やシンボルを選択する際には、回路図上のどこでもクリックできます。 
 
 

 

2.1.3 余分なシンボルや配線を削除する 

Special Case: Wires Inside a Symbol Boundary 
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場合によっては、シンボルの境界内の配線を削除したいこともあるかもしれません。以下の例では、入力ピンがまとめ

て短絡された比較器を使用しています。This procedure removes the wires, but leaves the symbol intact. 
 

 
 

配線の部分だけを削除したい場合には、次の手順に従います： 

1. Shift キーを押したまま、マウスの左ボタンを押しながらドラッグし、以下のように配線部分を選択します。 
 

 
 

2. 範囲を指定したら、マウスの左ボタンを離します。 

結果：ボックス内の配線が青に変わります－これはその配線が選択されたことを示しています。 
 

 
 

3. Delete を押します。 

結果：選択された配線が回路図上から消えます。 
 

 
 
 

 
 

There are times when your schematic will have wires which are exactly one grid square long, and you would like to delete 
these wires. This is difficult because the program enters the wiring mode whenever the mouse cursor is within one-half 
grid square distance from a wire end. Here are a few solutions to this problem: 

 
Disable the auto wiring by pressing and holding the Ctrl key when selecting the wire. 

1. Disable the auto wiring by pressing and holding the Ctrl key when selecting the wire. 

or 
2. Select the wire by dragging a box which encloses the wire. 

Special Case: Wires Which are Exactly One Grid Square Long 
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Once the wires are selected, you can press the Delete key to remove them from the schematic. 

 
▲ back to top 

 
 

 
 

回路図を保存するには、次の手順に従います: 

1. File > Save Schematic As...を選択する。 

2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 1_my_buck_converter.sxsch とします。 
 

この状態で保存された回路図は、こちらからダウンロードできます：1_SIMPLIS_tutorial_buck_converter.sxsch. 
 

▲ back to top 
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2.1.4 回路図を保存する 
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This section of the tutorial explains how to edit standard components. 2.1 シンボルと配線を追加するで保存した回路図

を使い、コンポーネントの値を変更することで、実設計をより正確に反映したものにします。 
 

 
 
 

 
 

In this topic, you will learn the following: 
How to edit symbols and change values for standard components. 
How to change probe labels. 
How to configure the waveform generator. 

 
 

 
 

The full load current for this design is 10A and the output voltage is 1.2V. The load resistance is therefore 120mΩ. 出力

負荷レジスターの抵抗を変更するには、次の手順に従います： 

1. R1 のシンボルをダブルクリックし、十字カーソルがラベルではなくシンボルの上にあることを確認します。 

Result: The Choose Component Value dialog box opens. 

2. 下記の通り、Result フィールドの値を 120m に変更します。 
 

 
 

3. Ok をクリックします。 

4. ステップ 1～3 を繰り返し、2 つのシンボルの値を下記のように変更します： 
 

参照名 コンポーネントの名称 変更後の値 
R2 ゲート抵抗 1.5 

V1 入力ソース 12 

2.2 標準コンポーネントの値を編集する 

In this topic: 
 
 

What You Will Learn 
2.2.1  Change Component Values 
2.2.2  Change Probe Curve Labels 
2.2.3 Configure the Waveform Generator 
2.2.4 Save your Schematic 

What You Will Learn 

2.2.1 コンポーネントの値を変更する 
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▲ back to top 
 
 

 
 

Although not strictly necessary from an electrical perspective, the curve labels should be renamed to indicate which 
circuit variables are represented on the graph waveforms. 厳密には必要ではありませんが、グラフの波形にどの回路の

変数が表されているのかわかるようにするために、曲線の名称を変更するとよいでしょう。 

 
 

プローブの曲線名称を変更するには、次の手順に従います： 

1. Probe1-NODE のシンボルをダブルクリックします。 

結果： Edit Probe ダイアログが開きます。 

2. Curve label テキストボックスで名称を VOUT に変更します。 
 

 
 

3. Ok をクリックします。 

4. ステップ 1～2 を繰り返し、下記のように他の 2 つのプローブの曲線ラベルを変更します： 
 

元の曲線ラベル 回路の変数 変更後のラベル 
Probe2 NODE スイッチングノード SW 

IPROBE1 インダクター電流プローブ IL 
 

▲ back to top 
 
 

 

2.2.2 プローブの曲線ラベルを変更する 

2.2.3  波形発生器の設定を行う 
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波形発生器は、様々な種類の周期波形を作ることのできる柔軟なデバイスで 
す。MOSFET Q1 を動作させるには、特定のパルス幅、周波数、振幅のパルス発生 
器が必要です。 

 
波形発生器をパルス源として設定するには、次の手順に従います： 

1. 波形発生器のシンボル、V2 をダブルクリックします。 

結果：Edit Waveformダイアログが開きます。 

2. ダイアログ右側の Wave Shape の部分で、Pulse ラジオボタンを選択します。 

3. 中央上部にある Frequency を 500k に、Duty Cycle を 11 に変更します。 

 Note:  The Edit Waveform Dialog is interactive, which means that as you make changes to certain fields, 
values for related fields are automatically calculated and updated. For example, after you change the Frequency 
to 500k, the Period is calculated and updated to 2u. The calculated values update on the dialog when you move 
the mouse to a new field. 

4. ダイアログの一列目の下の方にある Pulse を 5 に変更します。 
5. Deselect the Default rise and fall check box. 
6. In the Rise field, enter 0 to set a zero rise time. 

Result: The Edit Waveform dialog should now look like this: 
 

 
 

7. Ok をクリックして、変更後の値を保存します。 
 

ここまで終えたところで、最初のシミュレーションを開始し、さらなる最適化を進められる状態になりました。 
 

▲ back to top 
 
 

 
 

回路図を保存するには、次の手順に従います。 

1. File > Save Schematic As...を選択します。 

2.2.4  回路図を保存する 
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2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 2_my_buck_converter.sxsch とします。 
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Note:  You will use this schematic in the next section, 2.3 Edit Multi-Level Models. 
 

▲ back to top 
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This section of the tutorial explains how to edit multi-level models. You will start with the schematic that you saved in 
2.2 Edit Standard Component Values and then change more component values for this design. 

 

 
 
 

 
 

This topic addresses the following key concepts: 
Inductors and Capacitors used in SIMPLIS can have multiple model levels. A model level represents the modeling 
complexity of the device; for example, a single capacitor symbol can model an ideal capacitor or represent a more 
complex model such as a capacitor with ESR and ESL. 
The multi-level lossy inductor model has a built-in high frequency limit. At frequencies above the corner frequency, 
the inductor becomes resistive. 

 
 

 
 

In this topic, you will learn the following: 
How to edit symbols and change values on multi-level models. 
How to change the model level. 

 

 
 

Both the capacitor and inductor in this design are multi-level models, where the model level determines the parasitic 
elements included in the model. Four model levels, 0 through 3, exist for the capacitor. 

A level 0 capacitor is ideal and no ESR, ESL or leakage is modeled. 
As the level number increases, parasitic elements are added to the model. 
To learn more about the four model levels, click the Help button on the editing dialog to open the topic for the 
capacitor model. 

 
This design is already set to a level 1 model. To change the output capacitor value, follow these steps: 

1. Double click the C1 symbol. 
Result: The Edit Multi-Level Capacitor dialog opens. 

2. Change the Capacitance value to 220u as shown below. 

2.3 Edit Multi-Level Models 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
2.3.1  Change Capacitor Model Level and Value 
2.3.2 Change Inductor Model Level and Value 
2.3.4 Save your Schematic 

Key Concepts 

What You Will Learn 

2.3.1  Change Capacitor Model Level and Value 
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3. Click Ok. 
 

▲ back to top 
 
 

 
 

The inductor used in this design is also a multi-level model. The inductor has two model levels: 
Level 0 represents a pure inductor. 
Level 1 adds an equivalent series resistance (ESR). 

 
Both inductor model levels have a parallel shunt resistance that limits the high-frequency response of the inductor. This is 
important for reasons that will become apparent later in the tutorial; for now, however, remember that the inductor has a 
built-in upper frequency limit and, at frequencies above this limit, the inductor becomes a resistor, reflecting the real 
behavior of the inductor. 

 
To automatically calculate the shunt resistance value from the corner frequency, click on the Calc... button in the editing 
dialog. 

 
The inductance value for this design is 680nH. To change the inductor value, follow these steps: 

1. Double click the L1 symbol. 
Result: The Edit Multi-Level Lossy Inductor dialog opens. 

2. Change the Inductor value to 680n as shown below. 

2.3.2 Change Inductor Model Level and Value 
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3. Next you will change the inductor Shunt resistance parameter. To change the shunt resistance, follow these 
steps: 

a. Click on the Calc... button. 

Result: The Calculate New Shunt Resistance dialog opens with the 680nH inductance value copied from 
the main dialog into the Calculate New Shunt Resistance dialog. The dialog has a built-in calculator 
function which calculates the new shunt resistance value based on the inductance and the desired 
frequency. You can change the Frequency entry and see the Shunt Resistance value change. 

 

 
 

b. The default frequency value of 10GHz is suitable for almost all switching power applications. This is the 
frequency above which the inductor will become resistive. Click Ok on the Calculate New Shunt Resistance 
dialog to save the value to the Edit Multi-Level Lossy Inductor dialog. 
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Result: The calculated shunt resistance value of 42.7257kΩ is returned to the Edit Multi-Level Lossy 
Inductor dialog. 

 

 
 

4. Click Ok. 
 
 

 
 

回路図を保存するには、次の手順に従います。 

1. File > Save Schematic As...を選択します。 

2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 2_my_buck_converter.sxsch とします。 
4. When prompted to overwrite the existing file, click Yes. 

 Note:  You will use this schematic in the next section, 2.4 Edit Parameter-Extracted Models. 
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This section of the tutorial explains how to edit parameter-extracted models. You will start with the schematic that you 
saved in 2.3 Edit Multi-Level Models and then continue to make changes that more accurately reflect a practical design. 

 

 
 
 

 
 

This topic addresses the following key concepts: 
The correct model extraction voltage, current, and temperature parameters are required to produce an accurate 
PWL MOSFET model. 
The MOSFET SPICE model is not used in SIMPLIS simulations, instead SIMPLIS uses a PWL model which 
accurately reflects the actual SPICE model behavior. 

 
 

 
 

In this topic, you will learn the following: 
How to change the MOSFET SPICE model. 
How to extract a PWL model. 

 

 
 

In section 2.1 Add Symbols and Wires, you placed parameter-extracted models for the MOSFET and diode without 
considering the suitability of the models. The IRF530 MOSFET is a 100V device with a high on-resistance; when what 
you need is a 30V-rated device with a lower on-resistance. This design will use the Si4410DY MOSFET, which has a 
drain-source rating of 30V and an on-resistance of approximately 18mΩ. 

 
To change Q1 to use the Si4410DY model, follow these steps: 

1. Double click the MOSFET symbol. 
Result: The Extract MOSFET Parameters dialog opens. 

2.4 Edit Parameter-Extracted Models 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
2.4.1Change MOSFET SPICE Model 
2.4.2Change the Model Extraction Conditions 
2.4.3 Save your Schematic 

Key Concepts 

What You Will Learn 

2.4.1 Change MOSFET SPICE Model 
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2. Click the Select button to the right of the SPICE Model field. 
Result: The Select New Device dialog opens. 

 

 
 

3. In the Search field, type si441. 
Result: Si4410DY is the only model which matches the sub-string si441 in the Installed SPICE models list. 
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4. Click on the Si4410DY, and then click Ok. 
Result: On the Extract MOSFET Parameters dialog, the SPICE model for Q1 changes to Si4410DY. 

5. Leave the dialog box open to continue after reading about the parameter extraction routine. 
 
 

 
 

Next, you need to change the model extraction conditions to the values used in this circuit. The parameter extraction 
routine requires the following four circuit parameters: 

The Drain to source voltage in order to determine the MOSFET capacitance values. 
The Gate drive voltage to determine the conduction characteristics. 
The Drain current to determine the threshold and transconductance of the MOSFET. 
The Model temperature, which affects most parameters since this is the temperature at which the SPICE 
simulation is performed. 

 
For the optimum model accuracy, all four parameters should accurately reflect the voltage, current, and temperature of 
the actual circuit. 

 
To change the model extraction conditions, follow these steps: 

1. With the Extract MOSFET dialog open from the previous instructions, enter the values as shown in the 
image below. 

 

Parameter label Value 

Drain to source voltage 20 

Gate drive voltage 5 

Drain current 15 

Model temperature 55 
 

Result: The dialog should now look like the following: 

2.4.2 Change the Model Extraction Conditions 
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2. Click Extract. 
Result: The SPICE model Si4410DY is simulated at the supplied test conditions and a PWL model is extracted for 
use in SIMPLIS. 

 
 

 
 

回路図を保存するには、次の手順に従います： 

1. File > Save Schematic As...を選択します。 

2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 2_my_buck_converter.sxsch とします。 
4. When prompted to overwrite the existing file, click Yes. 

 Note:  You will use this schematic in the next section, 2.5 Change to a User-defined Model. 
 

▲ back to top 
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This section of the tutorial deals with user-defined models. You will continue with the schematic that you saved in 2.4 Edit 
 Parameter-Extracted Models and then change the diode to a user-defined model. 

 
 

 
 
 

 
 

This topic addresses the following key concepts: 
A user-defined diode model can be used to model an ideal synchronous rectifier, with the minimum of circuit 
components. 
Diode models are implemented with PWL resistors in SIMPLIS. 

 
 

 
 

In this topic, you will learn the following: 
How to model a synchronous rectifier with a user-defined diode. 

 
 

 
 

SIMPLIS Diode models are PWL resistors with a high off-resistance and a low on-resistance. The parameter-extracted 
models use a three segment model, where the third segment represents an intermediate resistance between the high 
off-resistance segment and the low on-resistance segment. 

 
The user-defined model uses a two segment model and you can enter the resistance and voltage values into the dialog. 
Although it might not be obvious at first, this model can represent an ideal synchronous rectifier with the following 
characteristics: 

The forward voltage of the diode is 0V. 
When the diode current is positive, the diode has a forward resistance equal to the on-resistance of the 
synchronous rectifier MOSFET. 
When the diode current is negative, the diode turns off and the resistance is high, representing the off-resistance of 
the synchronous rectifier MOSFET. 
Because the diode turns on and off in response to the circuit voltages and currents, the timing for the synchronous 
rectifier is ideal, that is, no dead time or drive signal is required. 

 
You will now change the diode to use the user-defined model and enter the parameters to make it behave like an ideal 
synchronous rectifier MOSFET. 

 
To change the diode to a user-defined model, follow these steps: 

1. Double click the D1 symbol. 
Result: The Extract Diode : D1 Parameters dialog opens. 

2.5 Change to a User-defined Model 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
2.5.1 Model a Synchronous Rectifier with a User-defined Diode 
2.5.2 Save your Schematic 

Key Concepts 

What You Will Learn 

2.5.1 Model a Synchronous Rectifier with a User-defined Diode 
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2. Click the User-defined radio button on the upper left side of the dialog. 
Result: The parameters on the right side of the dialog change to User-defined parameters. 

 
Note:  The User-defined parameters are set to the values calculated in the last parameter extraction. 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/2_5_change_to_user_defined_model.htm


2.5 Change to a User-defined Model 
 

 

 
 

 
 

3. Make the following changes to the User-defined parameters: 
 

Parameter label Value 

Label ideal_sr 

Forward voltage 0 

Forward resistance 10m 

Output Capacitance 0 
 

Result: The dialog should now look like this: 



2.5 Change to a User-defined Model 
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4. Click OK. 

Result: The diode now represents an ideal synchronous rectifier with a 10mΩ on-resistance and 100MegΩ off- 
resistance. The forward voltage drop is 0V. 

 
▲ back to top 

 
 

 
 

回路図を保存するには、次の手順に従います： 

1. File > Save Schematic As...を選択します。 

2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 2_my_buck_converter.sxsch とします。 
4. When prompted to overwrite the existing file, click Yes. 

 
この状態で保存された回路図は、こちらからダウンロードできます： 2_SIMPLIS_tutorial_buck_converter.sxsch. 

 
▲ back to top 
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2.5.2 回路図を保存する 
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Simulating the Design 

3.0 設計のシミュレーションを行う 
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In chapter 2, you created a synchronous buck converter schematic and changed the component values to suit this 
particular design. チュートリアルのこのセクションでは、SIMPLIS の解析タイプ 3 つすべてについて、設定およ

び実行の方法を学びます。 

基本的な過渡解析シミュレーション－ which is similar to the transient analysis in other simulators but much faster.  

周期動作点（POP: Periodic Operating Point）解析－バックコンバーターの定常動作点を割り出します。

POP 解析では、POP 解析の解析周期を決めるノードを特定するために、POP トリガーシンボルを追加する必

要があります。 

AC 解析－変調器、AC 注入源、MOSFET ゲートドライバーを追加し、回路図を配線し直したものです。You will 
also find the control-to-output, or plant response, of the converter. 

 
上記の解析をすべて行うと、回路図は次のようになります： 

 

 
 

▲ back to top 
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Topics in this chapter 
3.1 Set up a Transient Simulation 
3.2 Set up a POP Analysis 
3.3 Set up an AC Analysis 
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http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/3_1_set_up_a_transient_simultation.htm[2016/05/05 9:40:50] 

 

 

 

 
 

This section of the tutorial shows you how to set up a transient simulation for a synchronous buck converter. 
 
 

 
 
 

 
 

This topic addresses the following key concepts: 
The SIMPLIS transient analysis is similar to the transient analysis available in other simulators, but it runs much 
faster. 
Although the analysis settings are almost identical to SPICE transient analysis settings, the math used in each 
simulator is vastly different. This allows SIMPLIS to simulate circuits much faster than SPICE. 

 
 

 
 

In this topic, you will learn the following: 
How to set up the buck converter to run a basic transient analysis. 
How to enlarge a graph and zoom in and out to examine it more closely. 

 
 

 
 

過渡解析シミュレーションの設定を行うには、次の手順に従います： 

1. 2.2 Edit Standard Component Values でコンポーネントの値を変更した後に保存した回路図を開くか、または

2_SIMPLIS_tutorial_buck_converter.sxsch を開きます。 

2. 回路図エディターのメニューバーから、Simulator > Choose Analysis...を選択します。 

結果：Choose SIMPLIS Analysis ダイアログボックスが開き、「Periodic Operating Point」「AC」「Transient」

の 3 つのタブが表示されます。 
 

3. Transient タブをクリックし、3 つの設定を変更します。ここでは、過渡解析シミュレーションを 0 から 500μs ま

で実行し、回路図の最上位レベルの全ノードからのデータを保存するよう設定を行います。 

a. ダイアログボックス右上にある Select analysis セクションで、Transient の前のチェックボックスをクリック

します。 
b. Analysis parameters セクションで、Stop time を 500u に設定します。 

c. Save options セクションで、All の前のラジオボタンをクリックします。 

Result: The Transient tab should now look like this: 

3.1 過渡解析シミュレーションの設定を行う 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
3.1.1 Specify the Transient Analysis Settings 
3.1.2 Save your Schematic 

Key Concepts 

What You Will Learn 

3.1.1 過渡解析シミュレーションの設定を行う 
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4. ダイアログボックス下部の Run をクリックします。 

 注：すでに Ok を選択、または Enter キーを押している場合には、キーボードの F9 キーを押してくだ

さい。 

結果：シミュレーションが実行され、waveform viewer ウィンドウが開き、3 つのプローブの曲線が表示さ
れます。

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/3_1_set_up_a_transient_simultation.htm
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5. このグラフをさらに詳しく見るためには、ウィンドウを拡大し、以下に従ってズームイン/アウトの操作を行い

ます。: 

 ズームインするには、マウスの左ボタンを押したまま、グラフ部分に四角形をドラッグし

ます。 

 ズームアウトするには、Home キーを押します。 

 Ctrl+Z. 前のズーム倍率に戻すには、Ctrl+Z を押します。 

 注：シミュレーション結果を加工し、見やすいグラフにする方法については、第 4 章の最初の 2 つのトピック

（4.1 Output Curves to Separate Grids と 4.2 Reorder the Graph Grids）で詳しくご説明します。 
 

▲ back to top 
 
 

 
 

回路図を保存するには、次の手順に従います。 

1. File > Save Schematic As...を選択します。 

2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 3_my_buck_converter.sxsch とします。 
 

この状態で保存された回路図は、こちらからダウンロードできます：3_SIMPLIS_tutorial_buck_converter.sxsch. 

3.1.2 回路図を保存する 
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このセクションでは、このコンバーターの定常状態の動作を検証するために、SIMPLIS POP（Periodic Operating 
Point）解析を行います。 

 

 
 
 

 
 

This topic addresses the following key concepts: 
In order for the POP analysis to find the steady-state operating point it needs to know which node on the schematic 
represents the lowest periodic frequency. You identify the lowest periodic frequency node with a special SIMPLIS 
symbol, the POP Trigger Schematic Device. 

この POP トリガーモデルは、SIMPLIS 独自のもので、基準電圧および比較器が含まれています 

POP トリガーデバイスは SIMPLIS に対し、POP 解析の際にどの最上位ノードを使って新たな POP 周期の開始

を検出するのかを指示します。 

この回路図ノードは、システム全体が周期的になる最低周波数（言い換えれば、システム内のすべてのエネルギ

ー貯蔵素子が周期的な動作を示す最低周波数）でスイッチングするよう、POP トリガーを作動させます。For 
this converter, any voltage which switches at the 500kHz switching frequency can be used for the POP Trigger 
input. 

 
 

 
 

In this topic, you will learn the following: 
How to add a POP trigger to the schematic 

 
 

 
 

POP トリガーを追加するには、以下の手順に従います。 
1. Open the schematic that you saved after running the transient simulation 

or 
open 3_SIMPLIS_tutorial_buck_converter.sxsch. 

2. From the Part Selector, double click on the Commonly Used Parts category to expand the list. 

3. 展開したリストの中から Pop Trigger Schematic Device をダブルクリックします。 

4. インダクターのすぐ上に十字カーソルを持っていき、マウスの左ボタンを押して POP トリガーを配置します。 

 注：POP トリガーを配置した後、移動させたい場合には、マウスをシンボルに合わせ、左ボタンを押した

ままドラッグします。 

スイッチングノードを周期的なソースとして使用するには、次の手順に従って配線をします。 

3.2 POP 解析の設定を行う 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
3.2.1 Add a POP Trigger to the Schematic 
3.2.2 Set up the POP Analysis 
3.2.3 Save your Schematic 
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1. トリガーが選択されていないことを確認し、POP トリガーの左側のラインの端にカーソルを置きます。 

結果：カーソルが十字からペンシルに変わります。 

2. マウスの左ボタンを押し、左に向かって短い水平の線を引きます。 

3. もう一度マウスの左ボタンを押して角を作り、スイッチングノードの電圧プローブに接続するラインまで配線

を延ばします。 

4. 再度マウスの左ボタンを押して接続し、続いてマウスの右ボタンを押して配線を終えます。 

結果：回路図はこのようになります。 
 

 
 

5. このバージョンの回路図を保存するには、回路図エディターのメニューバーから File > Save Schematic を選択し

ます。 
 

▲ back to top 
 
 

 
 

POP 解析の指示を設定するには、次の手順に従います。 

1. 回路図エディターのメニューバーから Simulator > Choose Analysis...を選択します。 

結果：Choose SIMPLIS Analysis ダイアログが表示されます。 

2. Periodic Operating Point タブをクリックします。 

3. ダイアログボックス右上の Select analysis セクションで、POP にチェックを入れ、Transient からチェックを外

します。 

4. 回路の最大スイッチング周期を指定するには、ダイアログの Timing セクションに行き、Maximum period の値を

2.2μs に変更します。 

注：これは定常状態の周期の 110%になります。最大周期の設定値は、POP が定常状態を探す解空間を制限

します。最大周期の設定値はスイッチング周期よりも大きくなければなりませんが、スイッチング周期の 2 倍

以上には設定しないことをお勧めします。 

3.2.2 POP 解析の設定を行う 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/3_2_set_up_pop_analysis.htm
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5. 解析指示の設定を入力し終わったら、次のいずれかを行います： 

 Run ボタンをクリックする 

または 

 Ok をクリックしてデータを保存し、ショートカットキーF9 を押してシミュレーション

を実行する。 

結果：waveform viewer ウィンドウが開き、コンバーターの定常状態の波形が表示されます。 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/3_2_set_up_pop_analysis.htm
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このウィンドウでは、5 つの周期的スイッチングサイクルについて、VOUT、SW、IL の波形がプローブ付きで表示され

ます。Notice that the converter displays no settling behavior and the waveforms are in perfect steady-state. The POP 
algorithm can save enormous amounts of elapsed time by accelerating the simulation to the correct steady-state operating 
point. 

 注：アウトプットを加工してグラフを読みやすくする方法については、第 4 章の最初の 2 つのトピック（4.1 
Output Curves to Separate Grids と 4.2 Reorder the Graph Grids）で取り上げます。 

 
▲ back to top 

 
 

 
 

回路図を保存するには、次の手順に従います。 

1. File > Save Schematic As...を選択します。 

2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 4_my_buck_converter.sxsch とします。 
 

この状態で保存された回路図は、こちらからダウンロードできます：4_SIMPLIS_tutorial_buck_converter.sxsch. 
 

▲ back to top 
 
 

 

3.2.3 回路図の保存 
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You are now ready to set up the buck converter for an AC analysis. You first will add a basic pulse width modulator 
(PWM) to the circuit. 

 

 
 
 

 
 

This topic addresses the following key concepts: 
The SIMPLIS AC analysis simulates the time-domain, switching circuit model, no averaged model is needed. 
Although you could run an AC analysis on the schematic as it is, the AC analysis would have no additional 
information because the schematic has no modulator. 
Version 8.0 has a Multi-Level gate driver which can represent several kinds of gate drivers and will be used in this 
design. The driver symbol dynamically changes when you change the model level, depicting the model. 
You can search for symbols using the 

 

 
 

tool button. 
 
 

 
 

In this topic, you will learn the following: 
How to add a basic PWM modulator, MOSFET gate driver and a AC small signal source. 
How to set the analysis directives and run a POP and AC analysis on the converter. 

 

 
 

この演習では、保存してある最新の回路図を使うか

4_SIMPLIS_tutorial_buck_converter.sxsch を開きます。 
 

グリッドが表示されていない場合には、回路図エディターのメニューバーから View > Toggle Grid を選択します。 
 
 

 

3.3 AC 解析の設定を行う 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
Getting Started 
3.3.1 Prepare the Schematic 
3.3.2 Add the New Symbols 
3.3.3 Add Wiring to the Schematic 
3.3.4 Save your Schematic 
3.3.5 Change Parameter Values 
3.3.6 Setup and Run an AC Analysis 
3.3.7 Save your Schematic 

Key Concepts 

What You Will Learn 

Getting Started 

3.3.1 回路図を準備する 
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To make room for the new modulator symbols, you will need to move several symbols on the previously saved schematic 

 
To move the symbols, follow these steps in the schematic editor: 

1. Open the schematic that you saved after running the POP simulation 

or 
open 4_SIMPLIS_tutorial_buck_converter.sxsch. 

2. コンポーネントを選択して右に移動させるためには、V2 と R2 の間のウィンドウ上部に十字カーソルを置き、下

図のように右に向かってボックスを描いてすべてのコンポーネントを囲みます。 
 

 
 

結果：選択されたコンポーネントが赤から青に変わります。 

3. 青い線のどこかに十字カーソルを合わせ、選択されたコンポーネントを右に 20 グリッド分ドラッグします 

4. 下図で青く表示されている 4 つの配線をそれぞれ削除するためには、配線に十字カーソルを合わせ、マウス

の左ボタンを押し、Ctrl+X または Delete キーを押します。 
 

 
 

5. V2 のシンボルをクリックし、右に 2 グリッド分ドラッグし、下図のように V1 と同じ高さになるよう下に移動さ

せます。 
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2 つの電源と 1つの交流電源を追加するには、次の手順に従います。 

1. Commonly Used Parts のカテゴリーの中から Power Supply をダブルクリックします。 

2. 十字カーソルを V2 波形発生器の右側に持っていき、マウスの左ボタンをクリックして下記のように V3 を

配置します。 
 

 
 

Result: This voltage source V3 will be the duty cycle control for the power supply. 

3. 手順 1 を繰り返します。十字カーソルを D1 の上と左側に合わせ、マウスの左ボタンをクリックして下記の

ように V4 を配置します。 
 

 
 

Result: V4 will be the floating gate drive power supply. 
4. Commonly Used Parts のカテゴリーの中から AC source (for AC analysis)をダブルクリックし、十字カーソルを V3

シンボルの上に持っていき、クリックして下記のように交流電源を配置します。 

3.3.2 新しいシンボルを追加する 
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Result: This AC source V5 will perturb the circuit during the AC analysis. 
 

To place the Comparator and move some of the symbols, follow these steps: 
1. From the toolbar, find the tool button with the binocular icon 

 

 
 

. Click on the tool button to open the Search dialog. 
Result: The Search dialog opens. 

 

 
 

 Note:  You can also open the Search dialog with thePlace > Search Part... menu item. 
2. Enter com in the search field. 

Result: The symbols which contain the sub-string com are shown. 
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3. Select the Comparator - Classic (Legacy) entry and click Ok. 
4. Place the cross hair just to the right of V4 so that the negative input and inverted output line up with the R2 symbol, 

and click the left mouse button to palce the comparator U1 as shown below. 
 

 
 

Result: U1 in conjunction with the ramp source V2 will form the duty-cycle modulator, with V3 providing a duty 
cycle input. 

5. Click the line just above the U1 symbol text and drag the mouse to move it up 4 grid points. 
6. Hold down the left mouse button and draw a box around all of the symbols on the left side (V1, V2, V3, V5, and 

U1), and then drag them all to the left 6 grid points. 
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The next symbol for this design is the Version 8.0 Multi-Level MOSFET driver. 
 

To place a multi-level MOSFET driver, follow these steps: 
1. In the Part Selector, double click the MOSFET Drivers category and then double click Multi-Level MOSFET 

Driver (Version 8.0+). 
2. Place the cross hair between the comparator U1 and the resistor R2. 
3. Click the left mouse button to place the new symbol as shown below. 

 

 
 

Finally, you need a probe to generate the gain and phase curves. To add a Bode Plot probe, follow these steps: 
1. From the Commonly Used Parts category, double click Probe- Bode Plot - Gain/Phase - w/ Measurements, 

and move the cross hair to the top of the schematic above the POP Trigger symbol and then click to place it on the 
grid. 
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Result: A dialog opens for you to add common measurements to this Bode Plot probe. 
 

 
 

2. Uncheck Gain Margin and Phase Margin, leaving only Gain Crossover Frequency checked, and then click Ok. 
Result: The built-in Gain Crossover Frequency measurement is added to the probe. This measurement will be 
made every time the simulation is run. 

 
▲ back to top 

 
 

 
 

下の表を使い、回路図に配線を追加します。 You will need to add ground symbols to the ground returns of U1 and U2. 
The keyboard shortcut G places ground symbols. 

3.3.3 回路図に配線を追加する 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/3_3_set_up_an_ac_analysis.htm
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▲ back to top 
 
 

 
 

回路図を保存するには、次の手順に従います。 

1. File > Save Schematic As...を選択します。 

2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 5_my_buck_converter.sxsch とします。 

この状態で保存された回路図は、こちらからダウンロードできます：5_SIMPLIS_tutorial_buck_converter.sxsch. 
 

▲ back to top 
 
 

 
 

コンポーネントを追加したことで、波形発生器 V2 の用途をパルス源から変調器ランプの電圧源に変更しました。以下

の手順では、変調器ランプを 1V ピークからピークまでに設定し、DC 電源（V3）がコンバーターのデューティーサイ

クル（11%）に等しい DC 値（0.11V）になるようにします。 
 

波形発生器のパラメーターの値を変更するには、次の手順に従います： 

1. V2 シンボルをダブルクリックします。 

結果：Edit Waveformダイアログボックスが表示されます。 

3.3.4 回路図を保存する 

3.3.5 パラメーターの値を変更する 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/3_3_set_up_an_ac_analysis.htm
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2. ダイアログの右側にある Wave Shape セクションで、Sawtooth ラジオボタンを選択します。 

3. Pulse の値を 1V に設定します。 

4. Ok をクリックします。 

5. V3 シンボルをダブルクリックし、DC Voltage を 110mV に変更し、Ok をクリックします。 
 

To change values on the MOSFET driver, follow these steps: 
1. Double click on U2, the Multi-Level MOSFET Driver. 
2. Change the Model level to 0. 
3. Uncheck the Use delay checkbox. 
4. Click Ok. 

Result: The symbol for the MOSFET driver changes to represent the level 0 driver which uses on/off resistance 
switches to drive the MOSFET. Additionally, the delay block has been removed from the symbol indicating that 
the driver has zero delay. 

 
▲ back to top 

 
 

 
 

AC 解析を実行するには、次の手順に従います。 

1. 回路図エディターのメニューバーから、Simulator > Choose Analysis...を選択します。 

2. ダイアログの右側で AC をクリックして、下記のようにチェックを入れます。 

3.3.6 AC 解析を設定し実行する 
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注：POP のチェックボックスにもチェックが入ってグレーに変わり、POP 解析と AC 解析の両方が実行され

ることになります。For every AC simulation, SIMPLIS requires a POP simulation to be run first. 

3. Run をクリックします。 

または 
Ok をクリックしてから F9 を押します。 

Result: The control to output response of the buck converter is output to the waveform viewer. 
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Notice that the Gain Crossover Frequency is measured and displayed on the Gain curve legend at the top of the box. In 
this context the Gain Crossover Frequency is simply the frequency where the Gain reaches 0dB. As expected the Gain 
at low frequency is slightly greater than 20dB, and the control-to-output transfer function has a double pole at the LC 
frequency of approximately 12.5kHz. 

 
It is important to note that the AC response of this circuit is taken from the full, non-linear switching model, and no small 
signal AC model is required. As a result, the effects of parasitic elements in the design are accurately modeled and 
automatically included in the AC analysis. A simple example is the DC gain of the power stage. The DC gain is slightly 
lower than the predicted value due to losses in the circuit. 

 
 

 
 

回路図を保存するには、次の手順に従います： 

1. メニューバーから File > Save Schematic As...を選択します。 

2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 6_my_buck_converter.sxsch とします。 
 

この状態で保存された回路図は、こちらからダウンロードできます：6_SIMPLIS_tutorial_buck_converter.sxsch. 
 

In the chapter 4, you will separate the POP waveforms to make it easier to understand the converter operation and 

3.3.7 回路図を保存する 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/3_3_set_up_an_ac_analysis.htm
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performance. 
 

▲ back to top 
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4.0 シミュレーション結果の管理 
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チュートリアルのこのセクションでは、以下を行うことにより、固定プローブの設定を行って見やすいグラフにする方

法について学びます。: 

 Separate the waveforms onto individual grids and change the vertical order of the grids. 

 For each curve, change the number of simulation runs displayed on the waveform viewer. 

 Interactively make scalar measurements on the curves after the simulation completes. 
 Add scalar measurements to the fixed probe symbols. These measurements are automatically made 

after each simulation run. 
 

この章を完了すると、回路図は次のようになります： 
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Topics in this chapter 
4.1 Output Curves to Separate Grids 
4.2 Reorder the Graph Grids 
4.3Define Waveform Persistence 
4.4Add Scalar Measurements to Output Curves 
4.5 Add Scalar Measurements to Probes 
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This section of the tutorial explains the process of automatically outputting curves to separate grids. While there are 
several ways to interactively move curves to new grids on the waveform viewer (e.g. Curves > Stack All Curves), these 
methods need to be run after every simulation. Instead of describing the interactive methods, this topic focuses on 
automatically making these measurements by adding the measurement definitions to the fixed probes. 

 

 
 
 

 
 

This topic addresses the following key concepts: 
Why you might want to display curves on separate grids. 
The SIMetrix/SIMPLIS software does not graph vectors with different physical units on the same axis; instead it 
creates a new axes for each different physical unit. 

 
 

 
 

In this section, you will learn to the following: 
Why you might want waveforms on separate grids. 
How to output curves to separate grids. 

In the graph output from 3.3 Set up an AC Analysis, you had two tabs: simplis_pop1 VOUT (Y1) and simplis_ac1, these 
are the data groups created by SIMPLIS. 

 Note:  SIMetrix/SIMPLIS adds a integer at the end of the data group name to make the data groups unique. The 
number after the group names simplis_pop and simplis_ac might be different on your waveform viewer, depending on 
how many simulations you ran since you started the program. 

 
If you click on the simplis_pop tab, you should see three curves on one grid with two axes, as shown below. 

4.1 Output Curves to Separate Grids 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
4.1.1 Separate Curves onto Individual Grids 
4.1.2 Saving your Schematic 

Key Concepts 

What You Will Learn 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/4_1_separate_the_pop_waveforms.htm
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Notice in the illustration above that the voltages are grouped on Y1 axis and the currents are on the Y2 axis since each 
physical unit requires its own axis. 

 

一つのグリッド上の 3 つの曲線（赤：VOUT、緑：SW、青：IL）がある状態では、コンバータの動作や性能を把握しづ

らくなる可能性があります。例えば、1.2V の出力電圧は、SW 波形と同じ軸上にプロットされると、SW ノード波形の

方が相対振幅がはるかに大きいため、平らな線のように見えます。It makes sense to split the waveforms onto multiple 
axes, or grids, so that the curves with similar amplitudes or functions are grouped together. 

 
 

 
 

To separate the curves onto grids with one curve per grid, follow these steps: 

1. 開いている波形ビューワーを閉じ、回路図エディターに戻り、VOUT プローブをダブルクリックします。 

結果: Edit Probe ダイアログボックスが表示されます。 

2. Axis type の部分で Use separate grid を選択し、Ok をクリックします。

4.1.1 Separate Curves onto Individual Grids 
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3. F9 を押し、シミュレーションを再度実行します。 

4. 波形ビューワーで simplis_pop...タブをクリックします。 

結果： 出力電圧、VOUT が新しいグリッド上に表示され、波形に合うよう自動的に拡大縮小されます。 
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5. 波形ビューワーを閉じ、回路図エディターに戻り、IL プローブをダブルクリックします。 

6. Axis type の部分で Use separate grid を選択します。 

7. Axis name 欄に currents と入力します。 
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注：Axis name を入力することにより、インダクターの曲線が VOUT と同じグリッドに表示されないよう

にします。 

8. F9 を押し、シミュレーションを再度実行します。 

結果：下記の通り、それぞれの曲線が別々のグリッド上に表示されます。 
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▲ back to top 
 
 

 
 

回路図を保存するには、次の手順に従います: 

1. メニューバーから File > Save Schematic As...を選択します。 

2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 7_my_buck_converter.sxsch とします。 
 

この状態で保存された回路図は、こちらからダウンロードできます：7_SIMPLIS_tutorial_buck_converter.sxsch. 
 

In the next section, you will change the order of the grids. 
 

▲ back to top 
 
 

 

 
 

 

4.1.2 回路図を保存する 

 
Collected links 

3.3 Set up an AC Analysis 
7_SIMPLIS_tutorial_buck_converter.sxsch 
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This section of the tutorial deals with the order of the grids in the waveform viewer. 
 
 

 
 
 

 
 

This topic addresses the following key concepts: 
The default grid, which in this case contains the SW curve, is always the lowest grid in the waveform viewer. The 
default grid cannot be deleted, but it can be empty; that is it has no curves plotted on it. 
Grids other than the default grid are ordered from top to bottom by alphanumerically sorting the curve names on 
the grid. The order of the grids up to this point in the tutorial is determined by the curve names: IL and VOUT, with 
the IL grid appearing above the VOUT grid. You can change this order by assigning an arbitrary string to the probe 
symbol, the sorting algorithm will use this string in place of the curve name. 

 
 

 
 

In this topic, you will learn the following: 
How to change the vertical order of graph grids from: 

1. IL 
2. VOUT 
3. SW 

to 
1. VOUT 
2. IL 
3. SW 

 
 

 
 

グリッドの順序を変えるには、セクション 4.1 Output Curves to Separate Grids の 7_SIMPLIS_tutorial_buck_converter の
例を使い、次の手順に従います： 

1. 波形ビューワーを閉じ、回路図エディターに戻り、VOUT プローブをダブルクリックします。 

2. 左下隅にある Display order の Arbitrary string to specify order の下のテキストボックスに A と入力しま

す。 

4.2 グラフのグリッドを並び替える 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
4.2.1 Change the Grid Order 
4.2.2 Save your schematic 

Key Concepts 

What You Will Learn 

4.2.1 グリッドの順序を変える 
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Note:  Since the SW curve is on the default grid, you do not need to specify the order for the SW probe. 
 

 Note:  Any string which is alphanumerically less than IL will move the VOUT grid above the IL grid. The 
sort algorithm is case insensitive. 

3. Ok をクリックし、F9 を押してシミュレーションを再度実行します。 

結果：新しい波形ビューワーでは曲線の順序が変わっており、IL の上に VOUT が表示されています。 
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回路図を保存するには、次の手順に従います: 

1. File > Save Schematic As...を選択します。 

2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 8_my_buck_converter.sxsch とします。 
 

この状態で保存された回路図は、こちらからダウンロードできます： 8_SIMPLIS_tutorial_buck_converter.sxsch. 
 

▲ back to top 
 
 

 

 
 

 
 

 

4.2.2 回路図を保存する 

 
Collected links 

4.1 Separate the Pop Waveforms 
8_SIMPLIS_tutorial_buck_converter.sxsch 
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This section of the tutorial describes how many simulation runs of data are displayed on the waveform viewer. In 
SIMetrix/SIMPLIS this is controlled by the persistence value, which has both a global setting and a local setting on each 
probe. Which persistence value is used can be set on a probe-by-probe basis. 

 

 
 
 

 
 

This topic addresses the following key concepts: 
The waveform persistence determines how many simulation runs are displayed on the waveform viewer for each 
probe. 
The global persistence value is defined in the Graph/Probe/Data Analysis section of the General Options dialog. 
The default value is 0. 
A persistence value of 0 means that all simulation runs are displayed. This can be cumbersome when you run 
many simulations sequentially without closing the waveform viewer. 

 
 

 
 

In this topic, you will learn the following: 
How to change the global value of the waveform persistence. 
How to change the waveform persistence value for an individual probe. 

 
 

 
 

デフォルト値の 0 を変更するには、次の手順に従います: 

1. メニューバーから File > Options > General...を選択します。 

結果：Options/Preferences ダイアログボックスが表示され、Schematic オプションのタブが表示されます。 

2. Graph/Probe/Data Analysis タブをクリックします。 

3. 左側の上から 2 番目の Fixed probe global options の部分で、Default Persistence の横にある矢印ボタンを使って

数字を変更します。 

または 
0 を選択し、希望する数字（保持したい回数）を入力します。 

4.3 波形の持続性を定義する 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
4.3.1 Change the Global Persistence Value 
4.3.2 Change the Persistence on a Probe 

Key Concepts 

What You Will Learn 

4.3.1 Change the Global Persistence Value 
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4. Ok をクリックします。 
 
 

 
 

In the upper right corner of he Edit Probe dialog is a Persistence field, which normally has the default checkbox checked. 
On each probe you can specify the persistence or use the global persistence value defined in the General Options 
dialog. This flexibility allows you to customize how many curves are displayed on the waveform viewer, on a probe by 
probe basis. 

 
For most applications using the default persistence makes the most sense, which allows a single control on the General 
Options dialog to manage the persistence of all probes. 

 
To change the waveform persistence for a individual probe, follow these steps: 

1. In the schematic editor, double click the IL probe. 
Result: The Edit Probe dialog opens with default checked in the Persistence section as shown below. 

4.3.2 Change the Persistence on a Probe 
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2. In the Persistence section, uncheck default, and then use the arrow buttons to increase the number. 

or 
Select the 0 and type the number of runs you want to retain. 

3. Click Ok. 
 

▲ back to top 
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This section of the tutorial describes how to add measurements to curves in the waveform viewer. 
 
 

 
 
 

 
 

This topic addresses the following key concepts: 
SIMetrix/SIMPLIS has a powerful set of built-in measurements which can be applied to any curve. 
The Measure menu in the waveform viewer gives you access to the curve measurements. 

 

 
 

In this topic, you will learn the following: 
How to add measurements to a curve. 
How to access all of the measurements and functions available in the waveform viewer. 

 
 

 
 

グラフに測定値を追加するには、次の手順に従います： 

1. 回路図エディターから、F9 をクリックしてシミュレーションを実行します。 

2. 左上隅の波形ビューワーツールバーのすぐ下にある SW waveform にチェックを入れます。 

3. 波形ビューワーのメニューから Measure > Minimum を選択します。 

4.4 出力曲線にスカラー測定値を追加する 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
4.4.1 Add Measurements to the Curve 
4.4.2 View All Available Measurements 

Key Concepts 

What You Will Learn 

4.4.1 曲線に測定値を追加する 
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結果：先程 SW にチェックを入れた場所の下にあるグラフの説明部分に、SW 電圧波形の最低値が表示されま

す。 

 Note:   To see the complete label, you may have to adjust the splitter bar between the label and the tabs 
for the graphs. 
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使用できる測定の一覧を見るには、次のいずれかを行います： 

波形ビューワーのメニューバーから、Measure をクリックし、A More Functions...を選択します。 

または 
キーボードの F3 キーを押します。 

結果： Define Measurement ダイアログが表示され、より複雑な測定値やユーザー定義の測定値をグラフデー

タウィンドウに追加することができます。 

4.4.2 使用可能なすべての測定値を確認する 
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Define Measurement ダイアログについて詳しく知りたい場合には、SIMetrix User Manual の第 9 章をご参照ください。 
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This section of the tutorial describes how to automatically make the measurements described in 4.4 Add Scalar Measurements to Output Curves after a 
simulation completes by adding the measurements to the fixed probe symbols. 

 
Any built-in or user defined measurement can be added to the fixed probes on the schematic. Measurements added to the probes are then automatically 
executed after each simulation run with the scalar measurement output to the waveform viewer and optionally to the schematic. The full version of 
SIMetrix/SIMPLIS has this feature enabled by default. This feature is available in SIMetrix/SIMPLIS Intro for a time-limited period using the Unlock 
Features option. 

 

 
 

 
 

This topic addresses the following key concepts: 
The built-in measurements can be added to any fixed probe. 

Measurements assigned to probes will automatically be made after the simulation completes. 
One or more measurements can be added to multiple probes by selecting the probes and running the context menu Edit / Add Measurement.... 

 
 

 

In this topic, you will learn the following: 
How to add measurements to fixed probes. 
How to add the same set of measurements to multiple probes. 

 
 

 

プローブ測定機能のロックを解除するには、次の手順に従います： 

1. メニューバーから Help > Unlock Features...を選択します。 

結果： Get Unlock Code ウィンドウが表示されます。 

2. Unlock ボタンをクリックします。 

結果：「この機能のロックが解除されました。SIMetrix/SIMPLIS を再起動してください」という内容のメッセージが表示されます。 

3. SIMetrix/SIMPLIS を一旦閉じ、再起動します。 

 
 

 

回路図に固定プローブ測定を追加するためには、前回の回路図を再度開いた後に、次の手順を行います。回路図のコピーはこちらよりダウンロード可

能です：8_SIMPLIS_tutorial_buck_converter.sxsch. 

1. 回路図エディターで、VOUT というラベルのついたプローブをクリックし、右クリックで Edit / Add Measurement を選択します。（または、キ

ーボードのショートカット Ctrl+Alt+F7 を使います。） 

結果： Edit Probe Measurements ダイアログが表示されます。 

2. 一列目の Select Measurement ドロップダウンリストから Mean を選択します。 

3. 右側の Add Measurement ボタンをクリックし、2 つ目の測定値として Peak To Peak を選択します。 

4. 5 列目の Display on Schematic で、Mean と Peak to Peak の両方について Yes を選択します。 

5. ダイアログの下の方にある Ok をクリックし、プローブの測定値を保存します。 

4.5 Add Scalar Measurements to Probes 
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6. 回路図エディターで、IL プローブを選択して Ctrl+Alt+F7 を押し、上記の手順 2 と 3 を繰り返し、Mean と Peak to Peak を追加し、Ok をクリ

ックします。 

 注： Display on Schematic のデフォルトは No であるため、IL プローブと SW プローブについては追加で変更を行う必要はありません。 

7. 回路図エディターに戻り、SW プローブをクリックして Ctrl+Alt+F7 を押し、Minimum と Maximum を追加し、Ok をクリックします。 

8. 波形ビューワーが開いている場合には閉じ、F9 を押してシミュレーションを実行します。 

結果： 回路図に VOUT 曲線の測定値が反映され、グラフは 3 つの曲線すべてについて測定値が表示された状態になります。すべての測定値が

見えるようにするためには、波形ビューワーのタブのすぐ上にあるスプリッタ―バーをドラッグする必要があるかもしれません。 
 

 
 

 ヒント：いくつかのプローブに対して同じ測定を追加したい場合には、複数のプローブを選択して測定を追加することができます。その場合、

Edit Probe Measurements ダイアログに入力した内容は、選択したプローブそれぞれに適用されます。 

 

 
 

回路図を保存するには、次の手順に従います： 

1. File > Save Schematic As...を選択します。 

2. 回路図を保存する作業ディレクトリーを指定します。 

3. ファイル名は 9_my_buck_converter.sxsch とします。 
 

この状態で保存された回路図は、こちらからダウンロードできます：9_SIMPLIS_tutorial_buck_converter.sxsch. 
 

▲ back to top 
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In the previous sections, you have learned the basics of working with SIMetrix/SIMPLIS. Next, you will start building high- 
level models using a building block approach, adding onto the synchronous buck converter developed in the first four 
chapters. 
In this chapter you will learn: 

How to parameterize symbols using expressions and the schematic command (F11) window. 
How to select a POP Trigger schematic node. 
How SIMPLIS runs all three analyses in a specific order - POP, AC, Transient. 
How to add hierarchy to your design. 
How to determine the evaluated values for parameter statements. 

 
When you complete this chapter, your schematic will look like: 
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In this section of the tutorial, you will build a standard 3-pole, 2-zero voltage-mode compensator using a built-in 
parameterized OpAmp and passive components. 

 
After finishing this section, you will have a complete closed-loop synchronous buck switching power supply model like the 
following: 

 

 
 
 

 

5.1 Building a Compensator 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
5.1.1Build the Compensator Schematic 
5.1.2Assign Parameterized Values to Symbols 
5.1.3 Connect the Compensator to the Power Stage 
5.3.4 Disable Power Stage and Compensator Bode Plot Probes 
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This topic addresses the following key concepts: 
Symbols can use variables, or parameterized values, that help with schematic reuse. For maximum flexibility, the 
compensator schematic uses parameterized values. 
Each schematic has a command (F11) window which stores analysis directives and variable statements. The text 
in the F11 window is included in the simulation deck. 
Parameter values can be assigned or calculated in the command (F11) window. 

 
 

 
 

How to parameterize symbols using expressions and the F11 window. 
Why, based on how POP works, choosing the switching node as the periodic input in section 3.2 Set up a POP 
 Analysis was not the ideal choice. 
How to solve a common POP simulation error by selecting a different POP trigger schematic node. 
How to add parameter debug statements to the F11 window. 

 

 
 

In the previous chapters you learned how to place symbols using the parts selector and keyboard shortcuts. Starting with 
the 9_SIMPLIS_tutorial_buck_converter.sxsch schematic, use the following table of shortcuts and the illustration 
below as a guide to place the compensator symbols in the area below the power stage. 

Keyboard Shortcuts for Placing Compensator Symbols 
 

Symbol Parts Selector Location Keyboard Shortcut 
Multi-Level Parameterized Opamp (Version 8.0+) Analog Functions none 

Resistor Commonly Used Parts 4 

Capacitor (Ideal) Commonly Used Parts C 

Power Supply Commonly Used Parts V 

Bode Plot Probe (Gain/Phase) w/ Measurements Commonly Used Parts none 

5.1.5 Enter Parameter Values in the Command (F11) Window 
5.1.6 Try to Simulate the Design 
5.1.7 Move the POP Trigger Gate 
5.1.8 Verify Loop Stability 
5.1.9 Save your Schematic 

Key Concepts 

What You Will Learn 

5.1.1 Build the Compensator Schematic 
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▲ back to top 
 
 

 
 

After you have the drawn your schematic, double check that each resistor and capacitor has the reference designator as 
shown in the schematic above. 

  Important:  The design procedure uses these reference designators to calculate values; therefore, they must 
match the illustration, or the calculated values will be assigned to the wrong components. 

If your reference designators differ from those in the above image, follow these steps to change them: 
1. Select the resistor or capacitor symbol. 
2. Press F8. 

Result: A dialog opens for you to enter a new reference designator. 
 

 
 

3. Enter the reference designator as shown in the schematic above. 
 

When you assign parameterized values, you enclose the parameter name or expression in curly braces. In this tutorial 
you will use the reference designator text as the parameter name, for example, the parameterized value for the resistor 
R3 will be {R3}. 

 CAUTION: 
Both the opening { and closing curly brace } characters are required. Without an opening and closing curly brace, the 

5.1.2 Assign Parameterized Values to Symbols 
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expression will not evaluate correctly and the circuit will not simulate. 

To assign parameterized values to the resistor and capacitor symbols, follow these steps: 
1. Double click on each resistor or capacitor and change the value of the resistance or capacitance to a 

parameterized value. 
2. For the DC source V7, change the value to 0.6V. 

  Tip:  This will be the reference voltage for the compensator. 
 

Your compensator schematic should now look like the following: 
 

 
 

▲ back to top 
 
 

 
 

You will now close the feedback loop by connecting the compensator to the power stage. 
To connect the compensator to the power stage, follow these steps: 

1. Delete V3, the DC source which was the duty cycle control. 
2. Delete the wires connecting the AC source V5 to the comparator U1 input. 
3. Move V5 to the right side of the schematic. 

  Tip:  This will become the loop perturbation source. 

4. Wire the compensator to the power stage as shown in the image below: 

5.1.3 Connect the Compensator to the Power Stage 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_1_building_a_compensator.htm


Building a Compensator 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_1_building_a_compensator.htm[2016/05/05 9:47:04] 

 

 

 
 

 
 

5. Add the Bode Plot Probe across the V5 source. 

  Tip:  This will probe the loop gain of the converter. 

6. The output capacitor in this design has no ESR. In the previous simulations this was not an issue, but when the 
compensator is added, the ESR plays a role in calculating the compensator values. To include an ESR on this 
multi-level capacitor, double-click on C1 and set the model level to 2, and assign an ESR of 4mΩ. 

Result: The ESR value of 4m is displayed on the schematic. This indicates the model for the capacitor now 
includes an ESR. 

 
 

 
 

You now have three Bode Plot probes on the schematic and each probe will output a gain and phase curve with the 
default names of Gain and Phase. This will make a confusing graph with six curves, so in the next procedure, you will 
turn off the compensator and power stage probes as well as rename the curves generated by these probes. This will 
allow easy debugging later when you might want to see the power stage or compensator bode plots. 
To turn off the probes and rename the output curves, follow these steps: 

5.3.4 Disable Power Stage and Compensator Bode Plot Probes 
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1. Double click on the compensator bode plot probe and rename the gain and phase curves to Compensator Gain 
and Compensator Phase. 

2. Check Disable gain/phase at the top of the dialog, and then click Ok. 
3. Double click on the power stage bode plot probe and rename the gain and phase curves to Plant Gain and Plant 

Phase. 
4. Check Disable gain/phase at the top of the dialog, and then click Ok. 

 
▲ back to top 

 
 

 
 

In 5.1.3 Connect the Compensator to the Power Stage, you added parameterized values to each symbol by enclosing the 
variable name in curly braces { }. The curly braces form an expression and tell the program to stop and evaluate the 
expression; in this case, the program simply substitutes the value for the variables R3, C2, etc. in place of the 
expressions, {R3}, {C2}, etc. At this point in the design, the values for the compensator are not defined. Next, you will 
assign values to these variables using .VAR statements. 

Explaining how to compensate a 3-Pole/2-Zero voltage mode compensator is beyond the scope of this tutorial. Instead of 
dwelling on the compensator design process, which was taken from this application note, you will copy the text lines from 
this tutorial and paste them into the F11 window of the schematic. The .VAR lines are actually an entire design process 
taken from a spreadsheet and turned into variable statements. 

 
To enter the parameter values in the F11 window, follow these steps. 

1. Copy all text in the box below: 
 

 

5.1.5 Enter Parameter Values in the Command (F11) Window 

****************************** 
*** Circuit Specifications *** 
****************************** 

 
.VAR VIN = 12 
.VAR VRAMP = 1 
.VAR L = 680n 
.VAR C = 220u 
.VAR VOUT = 1.2 
.VAR VREF = 0.6 
.VAR ESR = 4m 
.VAR FXOVER = 80k 
.VAR FSW = 500k 

 
*** Calculated Parameters - not used in calculations 
.VAR FLC = 13012.31 
.VAR FESR = 180857.89 

 
.SUBCKT ONE_PULSE_SOURCE_I 1 2 vars: _T_RISE=0 _T_FALL=0 _DELAY=0 _V1=0 _V2=1 _PWIDTH=1u 
.NODE_MAP P 1 
.NODE_MAP N 2 
{'*'} _DELAY : {_DELAY} 
{'*'} _T_RISE : {_T_RISE} 
{'*'} _PWIDTH : {_PWIDTH} 
I1 1 2 PWL NSEG=4 X0=0 Y0={_V1} X1={_DELAY} Y1={_V1} X2={_DELAY+_T_RISE} Y2={_V2} 
X3={_DELAY+_T_RISE+_PWIDTH} Y3={_V2} X4={_DELAY+_T_RISE+_PWIDTH+_T_FALL} Y4={_V1} 
.ENDS 

 
********************************************************* 
*** Compensator Design - Find desired poles and zeros *** 
********************************************************* 

 
*** Place Second Zero at LC 
.VAR FZ2 = {1/(2*pi*SQRT(L*C))} 

 
*** Place First Zero at 75% of FZ2 
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2. In the schematic editor, press F11. 
Result: The command (F11) window opens at the bottom of the schematic. 

3. Drag the splitter bar between the command (F11) window and the schematic so the command window and the 
schematic take approximately 50% of the vertical space. 

4. In the command window, scroll down past the last statement, which is the 
 

 
 

line and use the keyboard shortcut Ctrl+V to paste the copied text in the F11 window below the .SIMULATOR 
DEFAULT line. 

Four sections of text are used to parameterize the compensator. 
The first section has design values. The statement .VAR VIN = 12 assigns the number 12 to the variable VIN. 
Although VIN is not used in the schematic, it is used in calculations for other variables. You could add VIN to the 
input source as a parameter {VIN}. 
The second section has the calculations for the compensator poles and zeros. The statement .VAR FZ2 = 

{1/(2*pi*SQRT(L*C))} assigns a value to the FZ2 variable. In this case, the value is the resonant frequency of the 
converter. 

 Note:  The variables L and C, as well as the global constant pi and the built-in function SRQT(), are used in 
the expression on the right side of the equals sign. The variables L and C must be assigned before they are used; 
therefore, the order of the lines in the window is important. The global constant pi and the function SQRT() are 
defined by the program. 

The third section calculates the actual resistor and capacitor values from the first section of the circuit 
specifications and the poles and zeros from the second section. 
The final section has debug statements. These statements output comments to the simulation deck so you can 
easily debug which values are being used in the compensator. For example, the values in the design will output 
the following to the deck file: 

 

 
 

A schematic saved at this state can be downloaded here: 10_SIMPLIS_tutorial_buck_converter.sxsch. 
 

▲ back to top 
 
 

 
 

When you try to simulate this design you will get simulation errors and SIMPLIS will automatically run a transient 
simulation so you can see what might be causing the errors. The waveforms will appear as follows: 

.VAR FZ1 = {0.75*FZ2} 

.SIMULATOR DEFAULT 

* FZ2 : 13012.3080131893 
* FZ1 : 9759.23100989196 
* FP2 : 375000 
* FP3 : 250000 
* C4 : 2.2e-009 
* R4 : 192.915082535631 
* R3 : 5366.67940889006 
* R6 : 5366.67940889006 
* R5 : 2848.37733925475 
* C2 : 5.72541552580328e-009 
* C3 : 2.23502610975745e-010 

5.1.6 Try to Simulate the Design 
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Clearly, the converter reaches a steady state operating point at the end of the transient simulation so you know that the 
loop is stable. The cause for the simulation errors is as follows: 

The initial conditions for the converter cause the error: the output voltage starts at 0V, and the compensator 
attempts to correct this with several cycles of full duty cycle. 
The modulator, at this stage of development, does not have either a duty cycle limit or a current limit; as a result, 
the inductor current reaches a high value before the output voltage overshoots. 
After the output voltage overshoots the reference, the compensator turns off the switch for several switching 
periods. 
During the portion of the simulation where there is no switching, SIMPLIS is monitoring the POP Trigger and at 
4.4μs, when twice the maximum POP period is reached, SIMPLIS thinks something has gone wrong with the 
circuit and outputs the following warning and error: 

 

 

*** WARNINGS REPORTED BY SIMPLIS *** 
**************************************** 
<<<<<<<< Error Message ID: 5020 >>>>>>>> 

Periodic Operating-Pt Analysis: 

Reaching a time duration equal to 
`4.40000e-006' without registering the 
triggering condition that defines 
the start of a period. Check your 
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Two possible solutions exist: 
Solution 1: Change the initial conditions of the circuit to initialize the circuit closer to the steady-state conditions. 
The compensator will then make small corrections to bring the converter into steady-state; the duty cycle will 
never reach 0 or 100%; and the POP analysis will succeed. This is a good design practice and you will probably 
need to do this at some point, especially with a more complex circuit. 
Solution 2: Change the location of the POP trigger gate so that the input signal crosses the POP trigger threshold 
on every switching cycle, independent of the commanded duty cycle. Since the oscillator node is independent of 
the commanded duty cycle, this is a good choice for the POP trigger node. 

For this tutorial, you will use Solution 2, moving the POP trigger gate to the oscillator node and changing the threshold of 
the POP trigger gate to 0.5V. 

 
▲ back to top 

 
 

 
 

To move the POP trigger gate to the oscillator node, follow these steps: 
1. Click on the POP trigger symbol to select it. 
2. Press Ctrl+X to cut the symbol. 
3. Press Ctrl+V to paste the symbol. 
4. Place the POP trigger symbol to the right of the oscillator V2. 

 

 
 

5. Double click on the POP trigger symbol, and change the Threshold parameter to 0.5V and click Ok to save your 
changes. 

6. Wire the input of the POP Trigger to V2 as shown in the image. 
 

▲ back to top 

circuit and/or initial conditions. 
 
*** END SIMPLIS WARNING REPORT *** 

 
*** ERRORS REPORTED BY SIMPLIS *** 
**************************************** 
<<<<<<<< Error Message ID: 5039 >>>>>>>> 

 
The periodic operating point (POP) analysis 
has failed to converge. AC analysis will 
not be performed. 

 
 
 
*** END SIMPLIS ERROR REPORT *** 

5.1.7 Move the POP Trigger Gate 
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The circuit should now run the POP and AC analysis configured earlier in the tutorial; however, the maximum frequency 
for the AC sweep is greater than the switching frequency which will result in plots with a small scale due to the high 
frequency noise. 

 
To change the maximum frequency, follow these steps: 

1. From the schematic editor menu, select Simulator > Choose Analysis.... 
2. In the Sweep parameters section on the AC tab, change the Stop frequency to 400kHz. 
3. Click Ok, or press F9 to run the simulation. 

Result: The simulation runs without errors and the bode plot for the converter is output to the waveform viewer. 
The Gain Crossover Frequency is 98kHz, the Phase Margin is 48 degrees and the Gain Margin is 13.5dB. 
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To save your schematic, follow these steps: 
1. From the menu bar, select File > Save Schematic As.... 

5.1.8 Verify Loop Stability 

5.1.9 Save your Schematic 
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2. Navigate to your working directory where you are saving your schematics. 
3. Name the file 11_my_buck_converter.sxsch. 

 
A schematic saved at this state can be downloaded here: 11_SIMPLIS_tutorial_buck_converter.sxsch. 
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In the previous section you added a compensator to the power stage, closing the control loop. The AC response of the 
converter shows adequate small-signal stability in terms of gain and phase margin. The next step is to verify the large- 
signal stability in the time domain when a load transient is applied to the converter output. 

 

 
 
 

 
 

SIMPLIS runs the three simulations (POP, AC, and Transient) in that order, which means that the transient 
simulation begins with the converter in steady state. 
When a transient simulation is run after a POP simulation: 

Only the transient data is shown on the waveform viewer. 
The transient simulation starts at the last data point from the POP simulation; that is, the POP simulation 
determines the initial conditions for the transient simulation. 

During a POP simulation, the pulse current source is held at its initial value of 0A. 
 
 

 
 

How to configure the circuit for a load transient test using a pulse current source. 
How the POP trigger conditions affect the initial conditions for the transient analysis. 

 

 
 

To set up the load transient simulation, you will add a pulse current source in parallel with the load resistor and change 
the output load resistor value. 

The converter will be set to start with a 50% load (5A) provided by the load resistor; the current source will apply a 
0-5A load pulse. 
The load timing will be set to apply a worst-case pulse load for this trailing edge modulator. 
The worst case pulse load timing conditions are as follows: 

The step-up occurs when the PWM modulator turns off the high side MOSFET. 
The step-down occurs when the PWM modulator turns the MOSFET on. 

The timing for the load transient can be set precisely during a POP/Transient analysis. 
 

To get started, you will need the schematic from the last section. You can download a schematic at this stage here: 
11_SIMPLIS_tutorial_buck_converter.sxsch. 

5.2 Set up a Load Transient Simulation 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
5.2.1 Add a Pulse Current Source 
5.2.2 Set up Analysis Parameters 
5.2.3 Change POP Trigger Edge 
5.2.4 Add the AC analysis to the POP/Transient Simulation 
5.2.5 Save your Schematic 

Key Concepts 

What You Will Learn 

5.2.1 Add a Pulse Current Source 
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To add the pulse current source, follow these steps: 
1. Select the inline current probe (IL); press Ctrl+C to make a copy; and then press Ctrl+V to paste the current probe 

to the right of the load resistor R1 as shown below. 
 

 
 

2. Double click on the probe, and rename the probe PULSE LOAD. 
3. In the part selector, double click on the Current Sources category to expand the list. 
4. Double click on Waveform Generator - Current Source and place that symbol to the right of the load resistor and 

the PULSE LOAD probe; and then wire it to the load resistor and current probe as shown below: 
 

 
 

To edit the waveform generator parameters, follow these steps: 
1. Double-click on I1. 
2. On the right side of the dialog in the Wave Shape section, select the One pulse radio button. 
3. In the left column, change Delay to 10.22u. 

 Note:  This delay time is equal to 5 switching periods plus a single on-time of the MOSFET. 

Result: This will delay the start of the load pulse until right after the switch turns off, producing the worst-case load 
transient. 

4. In the first column near the top of the dialog, change Width to 29.68u. 
Result: The Width, when added to the Delay and Rise parameters, will delay the load step-down time to 40us. 

5. Uncheck Default rise and fall . 
6. In the Rise field, enter 100n for the rise time. 

Result: The fall time is automatically set to 100n. The Edit Waveform dialog should now look like this: 
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7. Click Ok to save the new parameter values. 
8. Double click on the load resistor R1, and change the value to 240m. 
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Now that you have configured the schematic for the pulse load test, you are ready to set the analysis parameters to run a 
POP and transient simulation. The stop time for this simulation is set to 70us, which is long enough to for the converter to 
recover from the load transient and enter steady-state. 

 
To set the analysis parameters, follow these steps: 

1. From the menu bar in the Schematic editor, select Simulator > Choose Analysis.... 
2. Uncheck AC, and check Transient. 
3. Click the Transient tab. 
4. In the Analysis parameters section, set the Stop time to 70u. 

Result: The Transient tab should now look like this: 

5.2.2 Set up Analysis Parameters 
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5. To run the POP/Transient simulation, click Run button. 
Result: SIMPLIS runs POP and Transient simulations. After the POP simulation, SIMPLIS takes the initial 
conditions of the circuit and applies them to the Transient simulation. The Transient simulation starts with the 
converter in steady-state. 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_2_set_up_a_load_transient_simulation.htm


5.2 Set up a Load Transient Simulation 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_2_set_up_a_load_transient_simulation.htm[2016/05/05 9:47:38] 

 

 

 
 

 
 

If you look closely at the waveforms, you will notice that the timing appears to be incorrect. While the pulse load starts 
rising after the delay time of 10.22μs as setup in the previous section, the power stage waveforms are time-shifted by 
approximately 1μs, or half the period. Below is the waveform viewer zoomed in on the first 12μs: 
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The POP trigger conditions are the reason for this apparent time shift. In 5.1 Building a Compensator, you moved the 
POP trigger gate from the switching node to the oscillator source. The POP analysis settings include an edge direction, 
and the default setting is to trigger on the rising edge. Since the POP Trigger is finding the 500mV level of the rising edge 
of the oscillator sawtooth ramp, the POP period starts at a time midway between the switching node rising edge. Since 
the transient analysis begins at the final time point from the POP analysis, there is a 1μs time shift in the transient 
waveforms. In the next section you will change the POP Trigger Edge and see the effect on the transient waveforms. 
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To change the POP trigger edge, follow these steps: 
1. From the menu bar in the Schematic editor, select Simulator > Choose Analysis.... 
2. Click on the POP Tab and then select the Falling edge (logic high to logic low) radio button. 

5.2.3 Change POP Trigger Edge 
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Result: The dialog should appear as follows: 
 

 
 

3. Click Run to rerun the POP/Transient simulation. 
Result: The simulation runs again, but with a falling edge POP trigger condition. Because the POP Trigger 
condition is set to the oscillator falling edge, the MOSFET turns on slightly after t=0, t=2μs, t=4μs, etc. The timing 
of the pulse load is now aligned with the expected switching period and, therefore, the worst-case load transient 
timing conditions are used. 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_2_set_up_a_load_transient_simulation.htm


5.2 Set up a Load Transient Simulation 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_2_set_up_a_load_transient_simulation.htm[2016/05/05 9:47:38] 

 

 

 
 

 
 

It is now obvious how the output voltage deviation from steady-state is affected by the timing of the load pulse. The first 
simulation applied the pulse approximately 1us later (or earlier) in the switching period than the desired worst-case 
conditions. 

 
▲ back to top 

 
 

 
 

In the previous section, you set up the converter to run a POP and Transient simulation. This was done for clarity 
because a single graph tab with the transient results is output for each simulation. You can run an AC simulation in 
combination with both the POP and transient simulations. SIMPLIS will run the resulting POP/AC/Transient simulations 
in that order. 

 
Running a POP/AC/Transient simulation allows you to examine both the large- and small-signal behavior of the circuit. 

To add the AC analysis and view both types of behavior, follow these steps: 

5.2.4 Add the AC analysis to the POP/Transient Simulation 
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1. From the menu bar in the Schematic editor, select Simulator > Choose Analysis.... 
2. In the Select analyses section on the right, check AC. 
3. At the bottom of the dialog, click Run. 

Result: The waveform viewer opens with two tabs: an AC tab and a transient tab. The transient tab shows the 
large-signal behavior. 

4. To view the small-signal behavior, click on the AC tab. 
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To save your schematic, follow these steps: 
1. Select File > Save Schematic As.... 
2. Navigate to your working directory where you are saving your schematics. 
3. Name the file 12_my_buck_converter.sxsch. 

A schematic saved at this state can be downloaded here: 12_SIMPLIS_tutorial_buck_converter.sxsch. 
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In section 5.2 Set up a Load Transient Simulation, you modified the schematic to run a pulse load test on the complete closed 
loop converter. The schematic completed in that section is large and difficult to navigate. A natural progression is to add a 
level of hierarchy - that is, modify the schematic to use sub-blocks, or child components,with each sub-block representing 
some portion of the circuit, like the compensator. 

 
SIMetrix/SIMPLIS has an easy-to-use system for dividing schematics into sub-blocks. Each sub-block is called a Schematic 
Component and is saved as an individual file containing both the schematic and the symbol representing that sub- 
schematic. In this section you will create a schematic component out of the compensator portion of the schematic. 

 

 
 
 

 
 

The following key concepts are addressed in this section: 
Module ports define the electrical connections from the sub-schematic to the parent schematic. 
Schematic component files are containers similar to schematics but with an additional space reserved for the symbol. 
Symbols can be auto created by SIMetrix/SIMPLIS. 

After circuit blocks are divided into a hierarchy, you can create a truly modular design by swapping blocks that have 
common functionality and a common symbol. The hierarchical compensator block you create in this topic can also 
easily be used in other models. 

 
 

 
 

In this section of the tutorial, you will learn the following: 
How to add module ports to schematics. 
How to automatically create symbols for hierarchical components which connect to those module ports. 
How to edit symbols using the symbol editor. 
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Creating a hierarchical block out of a working schematic requires three major steps: 
Adding module ports to the schematic to identify which nodes connect to other blocks. 
Saving the schematic as a schematic component file. 
Creating a symbol which has pins corresponding to the underlying module ports. 

 

In this topic: 
 
 

Key Concepts 
What You Will Learn 
5.3.1 Create a Hierarchical Schematic Component From the Compensator
5.3.2 Create Symbol for Schematic Component 

5.3.3 Enlarge the Symbol
5.3.4 Move Symbol Pins 
5.3.5 Add Graphical OpAmp Symbol

5.3.6 Saving Symbols 

Key Concepts 

What You Will Learn 

5.3.1 Create a Hierarchical Schematic Component From the Compensator 
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Note:  An automated system exists to generate symbols for schematic components. 

 

To get started, you will need the schematic from the last section. You can download a schematic at this stage here: 
12_SIMPLIS_tutorial_buck_converter.sxsch. 

 
To add the module ports, rename them, and save the schematic, follow these steps: 

1. Delete the power stage components until you have only the compensator symbols and wires shown below: 
 

 
 

2. Using either the keyboard shortcut H or the menu selection, Hierarchy > Place Module Port, add module ports to the 
two inputs, the output, and the power supply of the OpAmp as shown below. 

 Note:  As you place the module port symbols, you can press F5 to rotate the ports as needed. 
 

 

3. To save your schematic component to a file, select File > Save Schematic As.... 

 Note:  To keep your reusable blocks separate from the top-level schematics, it is good practice to save your 
schematics to a sub-directory of your schematic directory. This tutorial uses D:\SIMPLIS Tutorial for the schematic 
and a sub directory, D:\SIMPLIS Tutorial\Modeling Blocks, for the schematic components. 

4. Name your schematic component 3p2zcompensator.sxcmp. 
 

Note:  The compensator schematic component file saved at this stage can be downloaded here: 
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3p2zcompensator_1.sxcmp. 

5. After saving your work, double click each module port and change its name to those in the table below: 
Compensator Module Port Names 

 

Port Function Port Name 
Reference Input (+ input) VREF 
Feedback Input (- input) FB 

Compensator Output COMP 
Power Supply Input VCC 

 

Result: When you finish renaming the module ports, the schematic should look like the following: 
 

 
 

6. Save your schematic component using Ctrl+S. The compensator schematic component file saved at this stage can be 
downloaded here: 3p2zcompensator_2.sxcmp. 
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With the compensator schematic open, select Hierarchy > Open/Create Symbol for Schematic..., or press S to create a 
new symbol for this schematic. 

Result: The symbol editor opens with an auto-created, default symbol. This symbol has all the connectivity information and 
symbol properties to netlist the underlying schematic correctly in SIMetrix/SIMPLIS. 

5.3.2 Create Symbol for Schematic Component 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_3_creating_hierarchical_schematics.htm
http://www.simplistechnologies.com/documentation/simplis/library/examples/simplis_tutorial/Modeling%20Blocks/3p2zcompensator_1.sxcmp
http://www.simplistechnologies.com/documentation/simplis/library/examples/simplis_tutorial/Modeling%20Blocks/3p2zcompensator_2.sxcmp


Creating Hierarchical Schematics 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_3_creating_hierarchical_schematics.htm[2016/05/05     9:48:17] 

 

 

 
 

 
 

 Note:  The symbol pins are automatically placed on each side of the symbol corresponding to the locations on the 
underlying schematic. For example, the VCC port is on the top of the schematic and is also on the top of the symbol. 

 
 

 
 

Although this symbol has all the needed electrical functionality, it could use some modification to make the function of the 
underlying block easier to see. In this next procedure, you will select the symbol pins and make the symbol larger than the 
auto-created size. 

 
To enlarge the symbol, follow these steps: 

1. Hold down the left mouse button and drag a box around the input pins on the right side of the symbol. Make sure your 
box includes any portion of the VREF and FB text so these elements will be selected. 

 

 
 

Result: The symbol pins, symbol pin text, and the vertical line on the right hand side are selected. 

5.3.3 Enlarge the Symbol 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_3_creating_hierarchical_schematics.htm


Creating Hierarchical Schematics 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_3_creating_hierarchical_schematics.htm[2016/05/05     9:48:17] 

 

 

 
 

 
 

2. Drag the selected portions of the symbol to the right 4 grid squares so your symbol looks like the image below. 
 

 
 

3. Using the same technique as steps 1 and 2, select the FB pin, the FB pin text and the horizontal line at the bottom of 
the symbol: 

 

 
 

4. Drag the selected portions of the symbol down two grid squares: 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_3_creating_hierarchical_schematics.htm


Creating Hierarchical Schematics 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_3_creating_hierarchical_schematics.htm[2016/05/05     9:48:17] 
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Now that you have enlarged the symbol, you can move the pins to locations which will make it easier to wire the components 
to the parent schematic. In the next procedure, you will swap the positions of the VREF and FB pins, and center the pins on 
the symbol. 

1. To move the VCC pin, select the pin and text with a box as show below: 
 

 
 

Result: The VCC pin and VCC text are selected. 

5.3.4 Move Symbol Pins 
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 Note:  The 3p2zcompensator text is also selected but this text is a symbol property and its position is controlled 
elsewhere. This symbol property is set to be centered on top of the symbol, so it does not matter that it is selected. 

2. Move the selected VCC pin to the right two grid squares, bringing it to the center of the symbol. 
 

 
 

3. Using the same technique as in steps 1 and 2, move the COMP, VREF and FB pins as shown in the diagram below: 

 Tip:  It will be easier to move the VREF and FB pins if you move the VREF pin before you move the FB pin. 
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The final step in modifying the symbol is to add graphical lines which describe the functionality of the underlying symbol. 
Although this step is completely optional, these graphical elements are helpful for others to identify the function for each 
block on your schematic. 

 
Drawing lines on symbols works just like drawing wires in the schematic editor. To add the lines, follow these basic 
guidelines: 

Double-click to start a line. 
Single-click to add a corner to a line. 
Right click or press Esc to end a line. 

Using these techniques, draw graphical lines on the symbol so your symbol appears as follows: 
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5.3.5 Add Graphical OpAmp Symbol 
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As mentioned in the introduction to this section, symbols for schematic components are saved to the schematic component 
file along with the schematic. Other symbols for built-in parts, such as the resistor and waveform generator, are stored in 
symbol libraries. The program knows that this symbol, however, is configured to be saved to the schematic. 

 
To save the symbol, follow these steps: 

1. Type Ctrl+S. 
2. Click Ok. 
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The compensator schematic component saved at this stage can be downloaded here: 3p2zcompensator.sxcmp. 
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This section focuses on placing hierarchical components and navigating between schematic levels. 
 

 
 
 

 
 

The following key concepts are addressed in this section: 
Schematic components can be placed with either the full path or with a path relative to the parent schematic. 
Schematic designs using relative path symbols are portable and can be easily shared with colleagues. 
The keyboard shortcut Ctrl+E allows you to descent into child components; Ctrl+U takes you back up to the parent level. 

 
 

 
 

In this section of the tutorial, you will learn the following: 
How to place the symbols contained in schematic component files. 
How to navigate between hierarchical schematics. 

 

 
 

In this section you will start with the schematic from the end of section 5.2 Set up a Load Transient Simulation and place the 
schematic component symbol created in 5.3 Creating Hierarchical Schematics. 

 
Open the schematic you saved at the end of section 5.2 Set up a Load Transient Simulation or use 
12_SIMPLIS_tutorial_buck_converter.sxsch from simplis_tutorial_examples.zip. 

 
To place the compensator hierarchical schematic symbol, follow these steps: 

1. Delete the compensator symbols you moved into the 3p2zcompensator hierarchical block in section 5.3 Creating 
 Hierarchical Schematics. 

Result: Your schematic should look similar to this: 

5.4 Using Schematic Components 

 
 
 

Key Concepts 
What You Will Learn 
5.4.1 Placing Schematic 
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2. From the menu bar, select Hierarchy > Place Component (Relative Path).... 
Result: A File Selection dialog opens. 

3. Open the Modeling Blocks folder. 
4. Select the 3p2zcompensator.sxcmp schematic component, and click Open. 
5. Place the symbol where the compensator components used to be: 
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6. Wire the compensator to the power stage. You can move symbols around to clean up the wiring. After this step, your 
schematic should look like the following: 
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To save your schematic, follow these steps: 
1. Select File > Save Schematic As.... 
2. Navigate to your working directory where you are saving your schematics. 
3. Name the file 13_my_buck_converter.sxsch. 

 Note:  A schematic saved at this state can be downloaded here: 13_SIMPLIS_tutorial_buck_converter.sxsch. 
 

▲ back to top 
 
 

 
 

When you save a schematic to a new name or save a schematic to a schematic component, the content of the F11 window is 
also copied to the new file. Normally, this is not a problem, but in this case, the compensator has unused analysis directives 
and the parent schematic has compensator calculations which are not used. While this extra text does not cause a simulation 
issue, the extra text might confuse a colleague who is unfamiliar with the design. 

 
In this section, you will remove the analysis directives from the F11 window of the compensator and the compensator 
calculations from the parent schematic. To remove the extra text from the main schematic, follow these steps: 

1. Press F11 to open the command window. 
2. In the command window, scroll down past the .SIMULATOR DEFAULT line and select all text below that line. 
3. Press Delete to remove the text. 

 Note:  You can undo editing in the F11 window with the keyboard shortcut Ctrl+Z, or by selecting the menu Edit > 
Undo. 

 
Result: The text remaining in the command (F11) window should be only the analysis directives: 

5.4.2 Save your Schematic 

5.4.3 Cleanup Top Level F11 Window 
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4. Press Ctrl+S to save your schematic. 
 
 

 
 

You need to descend into the schematic for the compensator and clean up the F11 window, using Ctrl+E to descend the 
hierarchy and Ctrl+U to ascend to the parent level. 

 
To clean up the compensator F11 window, follow these steps: 

1. Select U3, the 3p2zcompensator schematic symbol. 
2. Press Ctrl+E to descend into the schematic. 

Result: The schematic for the 3p2zcompensator opens just as if you opened it from a file browser. 

3. Press F11 to open the command window. 

Result: Since the compensator schematic is open, you are viewing the F11 window for the compensator component. 

4. Select the analysis directives from the first line, .SIMULATOR SIMPLIS, to the .SIMULATOR DEFAULT line. 
5. Press Delete to remove the text. 

Result: The text remaining in the command (F11) window should be only the compensator calculations: 
 

 

.S IMULATOR SIMPLIS 
*.AC DEC 25 1k 400k 
.PRINT 
+ ALL 
.OPTIONS 
+ PSP_NPT=10001 
+ POP_ITRMAX=20 
+ POP_OUTPUT_CYCLES=5 
+ SNAPSHOT_INTVL=0 
+ SNAPSHOT_NPT=11 
+ MIN_AVG_TOPOLOGY_DUR=1a 
+ AVG_TOPOLOGY_DUR_MEASUREMENT_WINDOW=128 
.POP 
+ TRIG_GATE={TRIG_GATE} 
+ TRIG_COND=1_TO_0 
+ MAX_PERIOD=2.2u 
+ CONVERGENCE=1p 
+ CYCLES_BEFORE_LAUNCH=5 
+ TD_RUN_AFTER_POP_FAILS=-1 
.T RAN 70u 0 

 
.SIMULATOR DEFAULT 

5.4.4 Clean up Schematic Component F11 Window 

****************************** 
*** Circuit Specifications *** 
****************************** 

 
.VAR VIN = 12 
.VAR VRAMP = 1 
.VAR L = 680n 
.VAR C = 220u 
.VAR VOUT = 1.2 
.VAR VREF = 0.6 
.VAR ESR = 4m 
.VAR FXOVER = 80k 
.VAR FSW = 500k 

 
*** Calculated Parameters - not used in calculations 
.VAR FLC = 13012.31 
.VAR FESR = 180857.89 

 
.SUBCKT ONE_PULSE_SOURCE_I 1 2 vars: _T_RISE=0 _T_FALL=0 _DELAY=0 _V1=0 _V2=1 _PWIDTH=1u 
.NODE_MAP P 1 
.NODE_MAP N 2 
{'*'} _DELAY : {_DELAY} 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_4_using_schematic_components.htm


Using Schematic Components 

http://www.simplistechnologies.com/documentation/simplis/simplis_tutorial/topics/5_4_using_schematic_components.htm[2016/05/05 9:48:40] 

 

 

 

 
 

6. Press Ctrl+S to save the compensator schematic. 
 
 

 
 

You are now ready to simulate the design. When you are working with a hierarchical design, you can simulate the design from 
any level of the hierarchy. 

 
To simulate this design, press F9. 

Result: The top level schematic comes into focus and the analysis directives defined in that schematic will be used. The 
waveform viewer opens with the results from the load transient simulation: 

{'*'} _T_RISE : {_T_RISE} 
{'*'} _PWIDTH : {_PWIDTH} 
I1 1 2 PWL NSEG=4 X0=0 Y0={_V1} X1={_DELAY} Y1={_V1} X2={_DELAY+_T_RISE} Y2={_V2} X3= 
{_DELAY+_T_RISE+_PWIDTH} Y3={_V2} X4={_DELAY+_T_RISE+_PWIDTH+_T_FALL} Y4={_V1} 
.ENDS 

 
********************************************************* 
*** Compensator Design - Find desired poles and zeros *** 
********************************************************* 

 
*** Place Second Zero at LC 
.VAR FZ2 = {1/(2*pi*SQRT(L*C))} 

 
*** Place First Zero at 75% of FZ2 
.VAR FZ1 = {0.75*FZ2} 

5.4.5 Simulate the Design 
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The schematic at this point is a complete hierarchical design. Although only one hierarchical block is used, the concepts in this 
chapter can be used to create larger and more complex hierarchical models. 

 
The electrical model for the synchronous buck converter is electrically unchanged by adding hierarchy. Moving the compensator 
into a hierarchical block allows that block to: 

Be used in other controllers which need a 3-pole/2-zero compensator. 
Replaced with a different compensator, using an alternative control approach. The symbol used in the hierarchical block 
can be saved to another compensator block, allowing drop-in replacement of the compensator block on the parent 
schematic. 

Parameterized with the values defined in the parent schematic. For example, the poles and zeros could be passed into 
the compensator from the synchronous buck converter schematic. Parameterization is described in the Advanced 
 SIMPLIS Training Course: Module 5 - Parameterization topic. 
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After completing the tutorial, you have a closed-loop synchronous buck converter model which uses a hierarchical 
schematic for the compensator. The compensator parameter values are calculated in the F11 window of the 
compensator from desired poles and zeros, effectively abstracting the design. 

 
This model runs in all three analysis modes: POP, AC, and transient. By running all three analyses, you can verify the 
large- and small-signal stability of the converter. 

 
 

 
 

Following are the key concepts presented in the tutorial. 
 
 

 
 

SIMPLIS is a time-domain simulator for all three analyses modes: POP, AC, and transient. 
The POP analysis finds the switching steady-state operating point of the circuit. 
The AC analysis finds the small-signal response of the circuit perturbed around the switching steady-state 
operating point found with the POP analysis. 
The AC analysis is performed in the time domain on the full switching PWL model; therefore, all non-linearities are 
included in the AC analysis. 
A successful POP analysis is required to run an AC analysis. 
During a POP/transient simulation, the transient simulation begins with the initial conditions found during a POP 
analysis. 

 
 

 
 

All models used in SIMPLIS are Piecewise Linear (PWL). 
MOSFETs and diodes are represented by collections of PWL devices with the parameters often calculated by built- 
in parameter extraction routines. 
Multi-level models can represent different schematic views depending on the model level. Built-in multi-level 
models include semiconductors, MOSFET drivers, inductors, capacitors, and a parameterized OpAmp. 
An ideal synchronous rectifier can be made using a user-defined diode. The resulting PWL resistor model has a 
zero-volt forward voltage and two segments, one each for the on and off resistances 

 
 

 
 

You can control where curves appear on the waveform viewer by changing properties of the fixed probe symbol. 
Measurements can be made on output curves either interactively with the waveform viewer menus or automatically 
by adding the measurement definition to the fixed probes on the schematic. 

 

 
 

Although the converter model at the end of the tutorial is relatively simple, it provides a good foundation on which to 
expand the model. The Advanced SIMPLIS Training course picks up where this tutorial leaves off. The Advanced 
SIMPLIS Training course, which is presented several times per year in different locations, provides expert level material 
in a tutorial format. You can access the Advanced SIMPLIS Training Course material here: Advanced SIMPLIS Training 
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 Course Material. 
 
 

 
 

The tutorial circuit is a good starting point for further exercises. A few suggested exercises are listed below. 
Modify the schematic to use hierarchical schematic components for all functional blocks. 
Modify the circuit to use a MOSFET for the synchronous rectifier, adding a driver and drive logic. 
Add current limiting. Examine the converter behavior when in current limit using a POP analysis. 
Explore different control techniques. Use hierarchical blocks to maximize reuse and to change between different 
control methods. 
Measure the efficiency of the converter by changing the MOSFET model level to level 2 and verify the switching 
losses for the circuit. 
Experiment with changing the MOSFET drive characteristics. Remove the gate resistor and use a level 1 or level 2 
MOSFET driver to tailor the gate drive current. 
Change the compensator to use parameters passed into the component from the parent schematic. 
Parameterization is described in the Advanced SIMPLIS Training Course: Module 5 - Parameterization topic. 
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